Not receiving the email with Gift Certificate coupon.


  • Default avatar
    kvo    
     2 years ago
    0

    Hi, I followed your directions here: (https://awodev.com/blog/sell-gift-certificates-online-your-virtuemart-store) to create a new Gift Certificate and it appears to work, but I don't get any emails that display the gift certificate information.  Are these directions for an older version? What could I be missing?

    Thanks!

  • Your avatar
    seyi    
     2 years ago
    0

    Hello,

    The first thing to check:

    In AwoCoupon > configuration > gift certificate product, have you set the order status for sending the gift certificate email?  And is your order in that status?
  • Default avatar
    kvo    
     2 years ago
    0

    Hi Seyi, Yes the order status for sending is CONFIRMED and the order status after sending is SHIPPED.  So on the two purchases I used to test with, they both show as shipped.
  • Your avatar
    seyi    
     2 years ago
    0

    Did the order go through the confirmed stage?

    Also in AwoCoupon configuration > giftcert, at the bottom, there is a debug section.  Set it to  yes and run another test.  If an error is caught, it should be displayed in that text box.
  • Default avatar
    kvo    
     2 years ago  last edited 2 years ago
    0

    I switched the order status after sending to CONFIRMED and did another purchase. The order went through and shows Confirmed in the VM Orders.  I still did not receive any email with gift certificate info. I just get the order confirmation and payment confirmation emails.  I did set debug to Yes and see no errors.
    I did not activate the Vendor in the config... does this need to be done?

    Also we are using Acymailing on this site.  Would that conflict with email sending from this component?

  • Default avatar
    kvo    
     2 years ago  last edited 2 years ago
    0

    There is error.  See below:


    2020-04-10 12:31:51 MESSAGE

    order[419]


    SELECT * FROM (

    .........

    GROUP BY order_item_id

    2020-04-10 12:31:51 MESSAGE

    order[419]

    no giftcert found in order

  • Default avatar
    kvo    
     2 years ago
    0

    I had the Disable gift certificate email to customer set as YES.

    I switched it to NO and did another test.  I got the certificate email now. So it seems fine.  

    But I also noticed in the debug for this order that it still says, 2020-04-10 12:49:39 MESSAGE

    order[420]

    no giftcert found in order

  • Your avatar
    seyi    
     2 years ago
    0

    Ok, so it is working?  In order_id of 420, are there gift certificate products?
  • Default avatar
    kvo    
     2 years ago  last edited 2 years ago
    0

    Hi Seyi, Yes it is working! It was just that I needed to switch this setting.  It seems like default upon installation should be set to NO for this option.  Disable gift certificate email to customer


    Thanks for your help!


    Also order_id 420 is a gift certificate.... can I just ignore this since it seems to be working?
  • Your avatar
    seyi    
     2 years ago
    0

    Yep, would ignore it at this point if everything is working now.  Make sure you turn off debug also.
  • Default avatar
    kvo    
     2 years ago
    0

    ok, thanks!