Coupon on order completed not being generated


  • Default avatar
    kaizendeep    
     3 months ago  last edited 3 months ago
    0

    Hi Seyi.


    I want users from the default shopper group to get a coupon sent to them specifically for an order completion, everytime they successfully place an order. There will be no limit to the number of coupons they can receive, but each coupon will  expire 60 days from the date of order.

    I can't seem to get this to work as the coupon in AWC is not being generated. Can you see if the values are correct in AWR as per the screenshot? Poor Man's Cron is also enabled.


  • Your avatar
    seyi    
     3 months ago
    0

    Change 'Minimum order total type' to 'Per order'
  • Default avatar
    kaizendeep    
     2 months ago
    0

    Okay, did that, but no luck. It's still not generating. Here's the AwoCoupons configuration:


    XdErX1G.jpg

  • Your avatar
    seyi    
     2 months ago
    0

    Have no emails been sent?  In aworewards > configuration, do you have the order status to trigger reward set?  And has your order moved through that order status?
  • Default avatar
    kaizendeep    
     2 months ago
    0

    Hi Seyi


    Yup the order is completed but no emails sent..

    AVktxFx.png

  • Default avatar
    kaizendeep    
     2 months ago
    0

    But i've noticed that when i did the update of AWR today, my rule has somehow become nested under "Apply first found match (Order / Everyone)". Is this normal?


    PGsOiIX.png

  • Your avatar
    seyi    
     2 months ago  last edited 2 months ago
    0

    kaizendeep @ Oct 28, 2020, 11:34:36 AM
    But i've noticed that when i did the update of AWR today, my rule has somehow become nested under "Apply first found match (Order / Everyone)". Is this normal?

    Not an issue, it is basically just letting you know processing has changed.  Previously you could create 2 order rules, and only the first order rule would run.  Now for that to happen, you have to nest it.  Now if you have 2 order rules not nested or in different nest, they would both run.

    kaizendeep @ Oct 28, 2020, 11:31:00 AM
    Hi Seyi


    Yup the order is completed but no emails sent..

    Ok, very strange.  In aworewards > installation check, do you see any errors?

    In the email template, skinfreaksorder20, is the body of the email blank?  Wondering if there is an issue with the email template.  you could change the order rule to points just to test.
  • Default avatar
    kaizendeep    
     2 months ago
    0

    The installation check looks okay, and here's a pic of the email settings.




  • Your avatar
    seyi    
     2 months ago
    0

    And the user you are using is in the default shopper group?

    I really do not know why it is not working.  Possible to send a private message with temp access to have a look?
  • Default avatar
    kaizendeep    
     2 months ago
    0

    Hi Seyi, PM sent. Do take a look.
  • Your avatar
    seyi    
     2 months ago
    0

    Took a look and to test removed the 'default shopper group' and triggered the cron and this triggered the reward.  Looking at the user, he is not in the default shopper group.