Index column size too large.


  • Default avatar
    turntex    
     9 days ago
    0

    AWO would not update through the component so I was told to download the file and install through Joomla!.  I tried and kept getting some 404 error when I would click on AWO and could not open it.  I decided to uninstall and try reinstalling the new version I downloaded.  Now I get the following message in the installer and my AWO coupon is GONE in Joomla!  HELP!  I am running Joomla! 3.8.12.

    Warning

    Index column size too large. The maximum column size is 767 bytes.

    Error

    Error installing component
  • Your avatar
    seyi    
     9 days ago
    0

    Hello,

    Doing a google search for this error, it seems the jist is basically this:

    The problem occurs because you are using an older mysql (or newer with wrong settings).
    1. Set innodb_file_format=Barracuda
    2. Set innodb_large_prefix=1
    3. Set innodb_default_row_format=dynamic
    If you do not have the innodb_default_row_format setting (introduced in 5.7.9), then you have to change your config/database.php to use 'engine' => 'innodb row_format=dynamic'

    This answer was grabbed from here:
  • Default avatar
    turntex    
     7 days ago
    0

    Hmm, never had a problem and I keep my system completely updated on a regular basis.  I regularly install updates to many components I support by purchasing and have never run into a problem.  It is all good though.  I reached out to a Joomla! developer who helps me on a regular basis when I need coding done or stuff beyond my expertise.  He changed up some stuff in the SQL queries in the install routine and it installed just fine.