Gift Certificate not being applied, Whole order going through Credit Card


  • Default avatar
    kvo    
     9 days ago
    0

    Hi, My last two gift certificate users complained that when they used their gift certificates and entered their credit card for the amount exceeding the certificate amt, that the whole amount was charged to their card. The coupon code doesn't show at all on the invoice.  I can't see anything wrong. Any ideas?
  • Your avatar
    seyi    
     8 days ago
    0

    Hello,

    It may be getting marked as used before the customer can pay.  Is this a Virtuemart site?  If so, go to awocoupon > configuration > triggers, and change

    'Order state to trigger coupon processing'

    From 'Order creation' to all your confirmed/paid statuses. 
  • Default avatar
    kvo    
     8 days ago
    0

    I did install an update to my one-page checkout and did a test and it worked properly, but I don't know if I can be certain that was the problem... so, if I change it to trigger on confirmed/paid statuses, would it show immediately in the cart? I also noticed the status of the certificate shows as an orange checkmark.  What would that mean?
  • Your avatar
    seyi    
     8 days ago
    0

    If you see the status now shows as 'orange', it has been changed to a customer balance and will not work as a coupon code anymore.  Only as a stored credit in a specific user account.

    In awocoupon configuration > awocoupon balance, you probably have this option set to yes:

    Changing it to confirmed/paid status basically means the coupon is not marked as used until the customer has paid.  So if they enter an order with the coupon, and it stays in the pending stage, it is not used.  If you leave it on 'order creation', then it would be marked as used.