Disabling "Case sensitive" is inoperant


  • Default avatar
    philippe16    
     17 days ago
    0

    Hello,
    I need to use your function "disable case sensitive", but it doesn't work.
    If I disable this parameter in awo config, I can type the coupon, the message of confirmation is ok, but the coupon not calculated.
    You can test here with coupon BIENVENUE saved in uppercase in the backend. When entered in lowcase, coupon is not applied. http://bb.a51.fr/
    I'm still working with VP One Page Checkout... https://nimb.ws/YgTDfZ

    Any idea?
    Thanks for your help
  • Your avatar
    seyi    
     17 days ago
    0

    Is the issue the error message?  If so, and you are using the latest, this may fix your problem:
  • Default avatar
    philippe16    
     17 days ago
    0

    I'm sorry, I realize I wasn't explicit.
    I need the coupon codes to be case-insensitive.
    So I unchecked the "case sensitive" checkbox in the plugin configuration.
    However, when you enter the code on the frontend in lower case while the code was recorded in uppercase, the coupon is not triggered, despite the information message. This is what you can see on the attached screenshot: https://nimb.ws/YgTDfZ
    Thanks for your help.
  • Your avatar
    seyi    
     14 days ago
    0

    I cannot produce this error.

    You should still update the code as in my previous messaege, that will fix the error display, where it shows successful eventhough the coupon has not been entered.    Then at the very list you can go to awocoupon > configuration > error message > debug and then run the code again in the front end.
  • Default avatar
    philippe16    
     14 days ago
    0

    Yes, I did this update, as it is for the same website :) So code is modified as explained in your post https://awodev.com/forum/awocoupon/help-section/custom-error-messages-are-inactive#post12293
    It solved the problem for error messages but I'm still facing a bug with case sensitivity.
  • Your avatar
    seyi    
     14 days ago  last edited 14 days ago
    0

    Ok, so testing again, if I set 'Case Sensitive Coupon Code' to 'Yes', this means the coupon is case sensitive, and what I find:
    - use a coupon in the right case, it works
    - use a coupon in the wrong case, does not work (which is correct), but wrong message of successfully accepting

    Nevermind the above, it is actually working fine for me.
  • Default avatar
    philippe16    
     14 days ago
    0

    Ok, I agree with you.
    But I need the coupon to be case NOT sensitive :) This is were the problem is, as explained in  my previous messages

  • Your avatar
    seyi    
     14 days ago
    0

    Ok, so start with the basics.
    In awocoupon > configuration, set 'Case Sensitive Coupon Code' to 'No'

    Temporarily disable vponepage checkout and test.
  • Default avatar
    philippe16    
     14 days ago
    0

    The same happens if I disable VP One Page Checkout.
    But, I just noticed something I didn't see the other times.
    The coupon entered with the wrong case is applied for the calculation (the total price is lowered) but its discount line is not displayed in the total.

    You have to change page and go back to the shopping cart page (not a simple refresh) to see the discount actually listed.
    So it would be a problem of javascript to display the discount?
  • Your avatar
    seyi    
     13 days ago
    0

    Is there someway I can test this myself?  You can send me a private message.
  • Your avatar
    seyi    
     13 days ago
    0

    Ok, took a look.  In my tests, when I enter a coupon code that is not in the same case as the coupon created
    - the coupon does does not show
    - the total is correctly updated to the total after discount

    If you refresh the page, the coupon code will eventually show.  I know you implemented this:

    And wondering if that code is somehow affecting this.  Can you revert back to the default?  Rename the override file so it is not found and uses vponepage default.   What happens then?
  • Default avatar
    philippe16    
     13 days ago
    0

    I renamed the entire directory overriding. The default file is now loading, and the same behaviour occurs.
  • Your avatar
    seyi    
     13 days ago
    0

    No idea, would have to debug directly.

    The only other thing I can think of is do you have the file:
    www/templates/[your_template]/html/com_awocoupon/coupondelete/default.php

    If you do, rename it so it is not called and see.
  • Default avatar
    philippe16    
     11 days ago
    0

    Hello, I renamed the directory for that override, but I'm sorry to say that the bug is still there...