Coupons not saving - page not loading in admin - eShop


  • Default avatar
    Alison Effting    
     7 days ago
    0

    Hi Seyi


    I tried to create a Buy X Get Y cross-selling coupon, and get a spinning ajax wheel on the admin end when I try to save it.

    I also noticed the other day if I try to access the Coupons on the main admin menu, I get the same. Checking on inspector it gives a 500 error 'Failed to load resource.'

    The other menus open (create a new etc.)

    I couldn't find anything on the forum using the search box, apologies if this has already been answered elsewhere.

    Regards

    Alison

  • Your avatar
    seyi    
     7 days ago
    0

    Hello,

    Possible to send private message with temp access to have a look?

  • Default avatar
    Alison Effting    
     7 days ago
    0

    Thanks for your response Seyi, have done that.
  • Default avatar
    Alison Effting    
     7 days ago
    0

    Seyi, I had a look at the plugins. I had prior VM component, and used AwoCoupon for VM. I see there are still 3 VM plugins enabled, and I'm not sure whether they are conflicting or at all necessary? Perhaps I should disable them? Vmcoupon, Vmpayment, Vmshipment. 
    Thanks.
  • Your avatar
    seyi    
     7 days ago  last edited 7 days ago
    0

    Those plugins should not matter, I disabled them anyway.

    After turning on debug mode, this is the error showing:
    1054 Unknown column 'h1.coupon_id_entered' in 'where clause'                                                    
    /usr/www/users/allisx/libraries/joomla/database/driver/mysqli.php:665 

    Even though you are using the latest version 3.5.7.0, your database looks like it is out of sync.  Please run these sql queries
    ALTER TABLE #__awocoupon_history MODIFY coupon_id INT;
    ALTER TABLE #__awocoupon_history ADD COLUMN `coupon_code` varchar(255) AFTER coupon_id;
    ALTER TABLE #__awocoupon_history CHANGE coupon_entered_id coupon_id_entered INT;
    ALTER TABLE #__awocoupon_history ADD COLUMN `coupon_code_entered` varchar(255) AFTER coupon_id_entered;

    UPDATE #__awocoupon_history h, #__awocoupon c SET h.coupon_code=c.coupon_code WHERE c.id=h.coupon_id;
    UPDATE #__awocoupon_history h, #__awocoupon c SET h.coupon_code_entered=c.coupon_code WHERE c.id=h.coupon_id_entered;

    Where #__ is your database prefix.  This should fix the issue.
  • Default avatar
    Alison Effting    
     7 days ago  last edited 7 days ago
    0

    Thanks Seyi, I will give that a go.


    Update:

    That seems to have done the trick, thanks. Will let you know if I encounter any further issues with this.

  • Default avatar
    Alison Effting    
     7 days ago
    0

    I've tested the coupon (as an automatic discount) and it's working; thanks again.
    I'm adding 2 more (a 2 +1 and a 1 + 1) and hope I get the ordering correct. Thanks for your always prompt assistance.