Coupon usage not recording


  • Default avatar
    zorigo    
     17 days ago
    0

    I set up a basic coupon for 30% off for a sale for a client.  The client asked how many times the coupon was used so I went in and looked and the History of Uses indicated 1.  However, when I look through the actual orders I can see that it has been used about 6 times.  When orders are processed, they are marked as complete.  When the client fulfills and ships  the order, they change the status to Shipped.


    Not sure if this has anything to do with it, but in the configuration under triggers I have the setting "Order state to trigger coupon processing" set to confirmed.


    Any idea why there is a discrepancy?

  • Your avatar
    seyi    
     17 days ago
    0

    Hello,

    On the same AwoCoupon configuration screen, there is the option 'Restore coupon's number of uses if order is not processed'.  Is this filled out?  If so what is the value?

    Also, the 6 orders you found, can you confirm the have all gone through the 'confirmed' stage?
  • Default avatar
    zorigo    
     17 days ago
    0

    seyi @ Jul 16, 2021, 1:35:59 PM
    Hello,

    On the same AwoCoupon configuration screen, there is the option 'Restore coupon's number of uses if order is not processed'.  Is this filled out?  If so what is the value?

    There is nothing filled out here.

    Also, the 6 orders you found, can you confirm the have all gone through the 'confirmed' stage?

    Yes, they are marked as confirmed after the order has been processed.  Then marked as shipped once they are shipped.

  • Your avatar
    seyi    
     14 days ago
    0

    Not sure.  Possible to have a direct look?  Can send temp access via private message.
  • Default avatar
    zorigo    
     14 days ago
    0

    Just sent you a message