Backend not in Spanish


  • Default avatar
    begoña    
     2 years ago
    0

    Hello,

    I just bought the AwoCoupon module and in the first tests I am seeing that the back office comes out in English, the same thing happens to me with AwoRewards.
    All the rest of the back office is correctly in Spanish so I think the joomla configuration is correct.

    eJpph0Z.jpg
    Any idea of ​​the problem?

    I am testing on localhost, I cannot give access.

    Thank you.
  • Your avatar
    seyi    
     2 years ago
    0

    Hello,

    I assume by Spanish, your language tag is es-ES.

    It may not have installed the language, especially if you installed it after installing AwoCoupon.  In that case, copy the files from the download:

    From download:
        language/admin/es-ES*
    To folder
        www/administrator/language/es-ES/

    And from folder
        language/site/es-ES*
    To folder
        www/language/es-ES/

  • Default avatar
    begoña    
     2 years ago
    0

    Thanks for the reply.

    I have copied the files manually and now it works fine.

    But joomla was correctly configured in Spanish es-ES before installing AwoCoupon and AwoReward, however the files in Spanish were not installed. Something is wrong.

    I have repeated the installation of the modules with a fresh joomla just installed v. 3.9.18 and AwoCoupon module cannot be installed.

    This is the error:

        0 Call to a member function get_home_link() on null
        /home/carlos/www/pruebas.local/public_html/joomla/administrator/components/com_awocoupon/awocoupon/library/class-awocoupon-library-http.php:39

    Call stack
    #     Function     Location
    1     ()     JROOT/administrator/components/com_awocoupon/awocoupon/library/class-awocoupon-library-http.php:39
    2     Awocoupon_Library_Http->request()     JROOT/administrator/components/com_awocoupon/helper/class-awocoupon-helper-update.php:242
    3     AwoCoupon_Helper_Update->install_languages()     JROOT/administrator/components/com_awocoupon/helper/class-awocoupon-helper-update.php:41
    4     AwoCoupon_Helper_Update->install()     JROOT/tmp/install_5ea2a9e4eed45/install.awocoupon.php:54
    5     awocouponInstall->install()     JROOT/tmp/install_5ea2a9e4eed45/install.awocoupon.php:27
    6     com_awocouponInstallerScript->install()     JROOT/libraries/src/Installer/InstallerAdapter.php:1048
    7     Joomla\CMS\Installer\InstallerAdapter->triggerManifestScript()     JROOT/libraries/src/Installer/InstallerAdapter.php:790
    8     Joomla\CMS\Installer\InstallerAdapter->install()     JROOT/libraries/src/Installer/Installer.php:521
    9     Joomla\CMS\Installer\Installer->install()     JROOT/administrator/components/com_installer/models/install.php:187
    10     InstallerModelInstall->install()     JROOT/administrator/components/com_installer/controllers/install.php:35
    11     InstallerControllerInstall->install()     JROOT/libraries/src/MVC/Controller/BaseController.php:710
    12     Joomla\CMS\MVC\Controller\BaseController->execute()     JROOT/administrator/components/com_installer/installer.php:19
    13     require_once()     JROOT/libraries/src/Component/ComponentHelper.php:402
    14     Joomla\CMS\Component\ComponentHelper::executeComponent()     JROOT/libraries/src/Component/ComponentHelper.php:377
    15     Joomla\CMS\Component\ComponentHelper::renderComponent()     JROOT/libraries/src/Application/AdministratorApplication.php:101
    16     Joomla\CMS\Application\AdministratorApplication->dispatch()     JROOT/libraries/src/Application/AdministratorApplication.php:159
    17     Joomla\CMS\Application\AdministratorApplication->doExecute()     JROOT/libraries/src/Application/CMSApplication.php:196
    18     Joomla\CMS\Application\CMSApplication->execute()     JROOT/administrator/index.php:51

    System:

    Joomla! 3.9.18 Stable [ Amani ] 21-April-2020 19:30 GMT
    mysql 5.7.29-0ubuntu0.18.04.1
    php 7.2.29-1+ubuntu18.04.1+deb.sury.org+1
    Apache/2.4.29 (Ubuntu)



    Regards.
  • Your avatar
    seyi    
     2 years ago
    0

    Do you have one of the supported shopping carts installed, Virtuemart, Hikashop, Eshop..etc?
  • Default avatar
    begoña    
     2 years ago
    0

    Sorry I forgot that little detail ;-)

    Now everything is working.

    Thank you.