Awo / PayPal issue


  • Default avatar
    dmytro5    
     4 months ago
    0

    AwoCoupon 3.5.6.2

    VM3

    Hello! I'm experiencing an issue. Will try to describe below:

    Scenarios:

    1) If a coupon has not been used then redirection to PayPal after 'Confirm purchase' works properly.

    2) If a coupon has been manualy typed and used then after 'Confirm purchase' the page is reloaded and the message 'Your cart has been updated' appears. If the 'Confirm purchase' button is taped for second time then redirecting to Paypal works.

    3) If a coupon was set to Automatic discount then 'Confirm purchase' and redirection to PayPal works properly.

    The question is how to resolve the issue with the 2nd scenario when the coupon is typed?


    Thanks in advance,

  • Your avatar
    seyi    
     4 months ago
    0

    Not sure, possible to test this directly?
  • Default avatar
    dmytro5    
     4 months ago  last edited 4 months ago
    0

    seyi @ Dec 6, 2020, 1:59:29 AM
    Not sure, possible to test this directly?
    Just sent a PM. Thanks


  • Your avatar
    seyi    
     4 months ago
    0

    This seems to be an issue with AwoCoupon and Onepage generic extensions.  What versions are you using?
  • Default avatar
    dmytro5    
     4 months ago
    0

    seyi @ Dec 10, 2020, 12:43:38 PM
    This seems to be an issue with AwoCoupon and Onepage generic extensions.  What versions are you using?
    Onepage for VM- 2.2.21

    Awo- 3.5.6.2

  • Your avatar
    seyi    
     4 months ago
    0

    That version of AwoCoupon is over 2 years old.  Can't really support it, you will need to update,  this issue might already be fixed in the latest.