automatic coupons and shipping rates


  • Default avatar
    JOMAISONJO    
     4 months ago
    0

    hi

    I recently contacted you because FreeShipping was calculated before any coupon is applied. I modified the code as you suggested here

    https://awodev.com/forum/awocoupon/help-section/free-shipping-2


    I noticed that if automatic coupons are enabled,

    the shipping costs are mentioned in the order lines, but only added to the totdal if the "SAVE" coupon button is clicked or the order goes to the payment page.


    Is there a way to have a sort of refresh when the cart page is opened?

    You can check at www jomaisonjo com adding any product to the cart.


    Please advice.

    Thanks


  • Default avatar
    JOMAISONJO    
     4 months ago
    0

    PS sometimes only going to the payment page bringts the shipping fee in the total...


  • Your avatar
    seyi    
     4 months ago
    0

    Not sure I understand the problem.  Are you saying you enter a product to the cart, go to the cart, and it does not show the shipping discount until after you refresh the page?

    I went to your website and do not see free shipping regardless of how many times I refresh:

    lKErdPi.png
  • Default avatar
    JOMAISONJO    
     4 months ago
    0

    hi

    now the automatic coupon is no longer valid,

    but I was able to reproduce the issue the same.

    try to add coupon SILVIA

    as you can see, the shipment fee is not added to the total.

    you have to go to the payment to see the correct total

  • Your avatar
    seyi    
     4 months ago
    0

    Ok, so what I see is after entering the coupon code, it treats shipping as 0 and discounts the product, even though there should be a shipping cost.  So the total is 7.99 cheaper than it should be.  Refreshing the page does not seem to fix the problem.  This is the issue?  When did this error start? I notice you are using rupostel one page checkout.  Did you recently update this?  Have you checked with them?  If you disable one page checkout temporarily, does it show correctly?

  • Default avatar
    JOMAISONJO    
     3 months ago
    0

    hi

    I've tried to disable OPC and this doesn't change the problem.

    honestly, I don't know when it started.

    you can try again now

    try to order something and you'll see that shipping rates are displayed but not added to the order total until you click to initiate the payment


    Thanks for checking


  • Your avatar
    seyi    
     3 months ago
    0

    Can you send me a private message with temp access to the site?  Need to test with without opc enabled and debug.
  • Default avatar
    JOMAISONJO    
     3 months ago
    0

    hi buddy

    done

    PM sent

    thanks

  • Your avatar
    seyi    
     3 months ago
    0

    Hello,

    It seems to be working fine.  I'm not sure if I just cannot produce the problem or it is working.  I did change 2 settings, in

    Virtuemart > configuration > checkout

    I set both of these to 'no preference' from 'none'

    - Enable Automatic Selected Shipment
    - Enable Automatic Selected Payment

  • Default avatar
    JOMAISONJO    
     3 months ago
    0

    it seems fine now.

    thanks