• Default avatar
    thomas95    
     3 years ago
    0

    Hi,

    basically the plugin works.
    But after I choose the payment 'eway', in the cart it still shows 'No shipment selected', which confuses customers.
    This does not happen when I choose paypal or standard payment.

    Also, after payment successfully done I receive an error:
    Warning: Creating default object from empty value in /home/wwwatcor/public_html/plugins/vmpayment/eway/eway.php on line 780
    (in demo mode)

    This is a rather urgent problem, the site is live.
    Thanks,

    error report: system default

    PHP 5.4.19
    Joomla! 2.5.14
    VM 2.0.22c
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    By 'No shipment selected' did you mean 'No payment selected'? I am not able to produce those errors you are receiving. Are you using some type of one page checkout? Are you using credit card or rapid3? After selecting the payment and you still see no payment selected, does it let you complete the order?

    The code on line 780 is code that is executed if there is an error processing the order. You can change it to the below to see if that gets rid of it:
    <?php
                    
    @$rtn->ewayTrxnStatus $this->xmlData['ewayTrxnStatus'];
    ?>
  • Default avatar
    thomas95    
     3 years ago
    0

    Hi seyi ,

    thanks for getting back to me.

    yes, 'no payment selected'.
    no, just standard VM checkout.
    using credit card, no rapid.
    Process Type: immediate
    does it let you complete the order? Yes, works just nice!

    I disabled error report currently, will try this code line later.

    I've send you PM with logins,

    thanks,
    Thomas

  • Default avatar
    thomas95    
     3 years ago
    0


    Hi seyi,

    any updates?
    My client starts getting mad at me..

    Thomas
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    The problem is solved.

    In www/plugins/vmpayment/eway/eway.php, I had to change
    <?php
        
    public function plgVmOnSelectedCalculatePricePayment(VirtueMartCart $cart, array &$cart_prices$payment_name) {
    ?>


    to
    <?php
        
    public function plgVmOnSelectedCalculatePricePayment(VirtueMartCart $cart, array &$cart_prices, &$payment_name) {
    ?>


    And that fixed it.
  • Default avatar
    thomas95    
     3 years ago
    0

    Thank you Seyi!

    all works properly.



    Thomas