Short url issues


  • Default avatar
    neilrjones    
     7 months ago  last edited 7 months ago
    0

    Seyi,

    I am trying to use the short URL option but having problems. I have enabled Google API and I know that works because the "Download Email address from Google Mail" works.

    In configuration/Invitation "Shorten registration url" is set to yes.

    In Google developer I have the URL Shortner API enabled

    The registration link that is being generated on the Invitation Form is:

    https://test.ocularit.com/index.php?option=com_aworewards&task=register&Itemid=500&id=

    As you can see the id is missing.  Also I expect the url to be much shorter.  Please advise.


    By the way, I left the credentials that I sent you earlier today enabled in case you need to go back in and check this issue out.  Thanks.


  • Your avatar
    seyi    
     7 months ago
    0

    Having a look now at AwoRewards on your site, and in admin there is another screen that is not listed in the links that shows you the users and their generated urls:

    administrator/index.php?option=com_aworewards&view=user

    And currently they all have their id missing, even after regenerating.  This seems to be an issue with php 7.  Will send you a fix privately.

    For google short urls, first make sure urls are generated with ids.  I have tested this locally and it is working fine for me.  For short urls, google uses the API Key, so just verify this is correct.  I know it works, because I changed yours to my api key and regenerated the link for an account.  It worked fine, you can see it on the page mentioned above.  It is changed back now.
  • Default avatar
    neilrjones    
     7 months ago  last edited 7 months ago
    0

    OK. Will review.
    Seyi,

    The ids are now being generated and I have double checked the Google api key (used copy/paste).  Could this be a PHP 7 issue?  The temporary account is still active.  Thanks.

  • Your avatar
    seyi    
     7 months ago
    0

    No dont think it is a php issue.  As I mentioned, I did changed it to my API key and was able to generate without problems, so it must be something else.    It might be a permissions issue with google.  In your google developer console, check the dashboard and make sure url shortner api is enabled. 
  • Default avatar
    neilrjones    
     7 months ago  last edited 7 months ago
    0

    Seyi,

    As the following attachments show, I believe that I have Google configured correctly.





    H'mm,

    Looks like me screen images did not post.


    Seyi,

    Any other ideas that I can try?  I am unable to upload images of my Google Developer screen which would show that the API key and the short url API is enabled. I am at a lost what to do next.  The temporary account is still active for you.  Thanks.