Emails in multiple languages


  • Default avatar
    comenaranjas    
     11 months ago
    0

    Hi Seyi


    I tried your method to translate invitation emails logging in as admin in different languages and storing text but it seems the component is not creating tables for each language. I checked aworewards_lang_text table and only es-ES is stored there although I tried saving it in english etc.


    I noticed using TinyMCE editor doesn't save the config (save and close buttons dont work), so I used JCE which in theory saves it correctly but only in main language, no matter what language the admin is in.


    Regards

  • Your avatar
    seyi    
     11 months ago
    0

    Hello,

    When you save invitation emails, do you mean invitation form under AwoRewards->invitation?

    Yes, I found that tinymce compatibility is broken in Joomla 3.6.4 in AwoRewards configuration.  But it should still work within rules and in the invitation page.
  • Default avatar
    comenaranjas    
     11 months ago  last edited 11 months ago
    0

    Sorry I meant AwoRewards/Configuration/Email/Points Notification  and also AwoRewards/Coupon Payout (Request) E-mail message.


    I'm trying to set up the content inside the editors in those sections per language.


    Regards


    PD: In case is related or AwoRewards requires update for joomla version VM had to make a fix for JCE since it wasn't showing new language in product descriptions and another fix for an editor. http://dev.virtuemart.net/projects/virtuemart/repository

    Changes by Maik Künnemann

  • Your avatar
    seyi    
     11 months ago
    0

    I have tested this with JCE and it is working for me, no issues.  The text is saved into the lang_text table in the correct language.

    Ok, here is the fix for TinyMCE, maybe using that will work better for you:

    in the file www/administrator/components/com_aworewards/views/config/tmpl/default.php, you will find these strings in 2 different places:

    params-sponsor_message
    params-sponsor_email_point_message
    params-frontend_invitationdesc
    params-payout_auto_sys_email_body
    params-payout_request_sys_email_body


    Now you need to alter them by changing the dash (-) to an underscore (_).  So the strings should now look like this:
    params_sponsor_message
    params_sponsor_email_point_message
    params_frontend_invitationdesc
    params_payout_auto_sys_email_body
    params_payout_request_sys_email_body


    That should fix the issue with TinyMCE
  • Default avatar
    comenaranjas    
     11 months ago  last edited 11 months ago
    0

    I have made modifications to the file you mentioned and that allows buttons to work again for TinyMCE thanks, however the language is only being saved in my main language.

    I tried saving several times in my other languages in different sections like invitation email e-mail message and Configuration/Email/Points Notification  and also AwoRewards/Coupon Payout (Request) but the text is always stored as spanish showing es-ES only in the aworewards_lang_text table.

    I tested as superuser and admin saving texts in backend in different languages but no entries are being created for additional languages.


    Regards

  • Your avatar
    seyi    
     11 months ago
    0

    Hello,

    Possible to send temp admin access via private message to look at this?
  • Default avatar
    comenaranjas    
     11 months ago
    0

    Yes thank you, PM with details send,


    Regards 

  • Your avatar
    seyi    
     11 months ago
    0

    Thanks for the access.  Just tested it and it seems to be working fine for me.  In the English version, I added the text 'En".  I f you look in the lang_text table, I am confident you will see the new string.

    When you are switching languages, do you switch the language of 'site' or 'administrator'.  Because this will only work if you switch 'administrator', which is not shown by default.

  • Default avatar
    comenaranjas    
     11 months ago
    0

    Works perfectly Seyi, thank you! I see your text in the table now.

    I was switching language directly at website.com/administrator thinking that was changing the language for the administration in the same way.

    So to change it correctly I went to extensions/languages/select administrator and changed default language. Then wrote text in Awo and now it appears in the tables as you told me.


    Regards