Automatic discounts not working after upgrade...


  • Default avatar
    ovoman    
     a year ago
    0

    Hi,

    I recently upgraded my website to Joomla 3.3.6 and Virtuemart 3.0.3 and I just noticed that the automatic discount feature doesn't seem to work anymore.

    There is still a (discount) showing on the right side of the coupon field but it brings the total of the cart to $0 instead of applying the discount programmed by the coupon code...

    Help please!

    Thanks.

  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    What version of AwoCoupon is this? Also do you have a onepage checkout extension installed?
  • Default avatar
    ovoman    
     a year ago
    0

    It's version 2.3.5.

    We don't have a one page check-out installed yet but we working on one to be implemented later this week.

  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    Ok, just rereading your post. First you are using virtuemart 3.0.3. This is a development release and not stable. You need an even number to be stable 3.0.2, 3.0.4, etc. I would suggest upgrading to 3.0.4. It might not make a difference, but best to be stable. Can you give details of the coupon you have in automatic discount so I can test it locally?

    So the problem is the discount is wrong? It is giving a discount but it is not correct? Have you tried disabling the automatic discount and entering it as a normal coupon code?
  • Default avatar
    ovoman    
     a year ago
    0

    Ok, I'll look into upgrading to 3.0.4 but we're just coming out of a painful upgrade and we have many VM layout customizations...

    I have disabled the automatic discount and tested the same coupon as a normal coupon and it worked just fine. That's why I'm saying it's a problem with the automatic discount feature.

    Here are the screenshots related to this coupon code:

    https://www.dropbox.com/s/qgc7tafqaprgzr1/Screenshot%202015-02-23%2015.29.56.png?dl=0

    https://www.dropbox.com/s/frb733gdm4s1eus/Screenshot%202015-02-23%2015.31.51.png?dl=0

    https://www.dropbox.com/s/wc67824hemva4u5/Screenshot%202015-02-23%2015.42.09.png?dl=0

    Thanks!
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    Looking at the interface of AwoCoupon in the image, that is not version 2.3.5. Can you look on the dashboard, you should see the version you are using there. Version 2.3.2 is the first version of AwoCoupon that should work with Virtuemart 3.x well, so you should at least get that installed.

    I tested the automatic discount using your coupon settings in Virtuemart 3.0.4, AwoCoupon 2.3.5, and it worked without problems.
  • Default avatar
    ovoman    
     a year ago
    0

    Hi Seyi,

    So I successfully installed the latest version available on your site but it triggered a fatal error message and my products and my cart were not accessible anymore. This message was loaded when I tried to go to the cart or access one of my product pages:

    Fatal error: Class 'JElement' not found in /home/aquaovo/public_html/administrator/components/com_virtuemart/elements/vmjpluginwarning.php on line 23

    I temporarily fixed it by unpublishing the "VmShipment - Awocoupon Free Gift Certificates" plugin but now nothing seems to be working and my coupons are not applying in the cart.

    https://www.dropbox.com/s/n8lqix7s3oxhfff/Screenshot%202015-02-24%2010.18.59.png?dl=0

    Do you have a fix for this?

    Thanks!

  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    I am looking at Virtuemart's directory structure now and that path in your error does not exist:
    http://dev.virtuemart.net/projects/virtuemart/repository/show/trunk/virtuemart/administrator/components/com_virtuemart

    So it is really hard for me to tell what is going on there.

    When you say nothing seems to be working, are you referring to coupons? Go to extensions->plugins, and filter by vmcoupons. Do you have just AwoCoupon enabled? If the answer is yes, then try disabling AwoCoupon, do system virtuemart coupons work?
  • Default avatar
    ovoman    
     a year ago
    0

    Hi,

    Yes, I mean the coupons I already have enabled in AwoCoupons.

    I checked the plugins and VMCoupon - AwoCoupon was the only plugin enabled. https://www.dropbox.com/s/o0ja8rq0ehqdc49/Screenshot%202015-02-24%2014.35.28.png?dl=0

    Then I tried disabling it and I created a coupon in virtuemart and it worked. It doesn't work if the VMCoupon - AwoCoupon is still active.

    M.
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    Not really sure what is going on, possible to send a private message with temp admin access to have a look?