why am I having so many problems


  • Your avatar
    seyi    
     5 years ago
    0

    Hi,
    why am I having problems with my tax and shipping costs? system versions are shown in my footer, is it worth while me uninstalling AwoCoupon, upgrading VM to the latest release and re-installing AwoCoupon to see if this fixes everything? I've spent 2 days now trying to impliment AwoCoupons and running at a loss as I've charged my client a fixed price for the insallation.

    Don't get me wrong I'm appreciative of your hard efforts in creating a component that fills a huge gap in VM's functionality, and your support is second to none, but why am I having these problems?

    Cheers,
    Philip
  • Your avatar
    seyi    
     5 years ago
    0

    Unfortunately that is one of the shortcomings of the current Virtuemart. If you did a search in the forum you will see there are alooot of tax questions. Dont think upgrading will help too much.

    For tax, Im assuming you are doing discount before tax? If so you have checked the box in Virtuemart configuration. AwoCoupon configuration also has a checkbox for the tax, have you tried toggling that to see if it helps?

    I also wrote a blog a while back detailing problems with vm 114:
    http://awodev.com/blog/virtuemart-coupon-error-discount-before-tax
  • Default avatar
    webdesco    
     5 years ago
    0

    Hi Seyi,
    i'm doing discount after tax as retail in the UK has the VAT included. I have the box in virtumart unchecked and the one in AwoCoupon checked. Changing either/both does not solve the problem. See my other posts re: tax issue for Gift Vouchers.

    I've got lost with which hacks I've implimented, so I've restored the site and the database from a backup I made before installing AwoCoupon Pro. I'll wait until I hear from you regarding the coupon/gift certificate tax issue before re-installing AwoCoupon Pro.