URGENT Issue with Virtuemart / Joomla User database / signups, using AwoCoupon


  • Your avatar
    seyi    
     4 years ago
    0

    AwoCoupon for Virtuemart - latest free version.
    Joomla Version 1.5.25
    VirtueMart 1.1.7 stable

    Having some major issues with my site.

    I believe it "may" be related to a AwoCoupon module I recently installed.

    Basically what happens is:

    having some major issues when I do the following:

    1. add a item to my cart.
    2. checkout.
    3. fill in details for a new customer.
    4. Activation link is sent to my email address.
    5. I then click on the activation link and then go back to MY CART.
    6. I then click CHECKOUT and get the following error message:

    "Info: You are not a Registered Customer yet. Please provide your Billing Information."
    (Please see screen2.png attached > http://www.skynetdigital.com.au/screen2.png)

    7. I then proceed to fill out that information again, and then press SEND REGISTRATION button.

    It then displays: "Info: You are not a Registered Customer yet. Please provide your Billing Information."
    (Please see screen2.png attached > http://www.skynetdigital.com.au/screen2.png)

    It is not saving the user information and I cannot proceed to checkout due to this error.

    I then went into the Joomla backend admin section and noticed the user was added there, however if I then navigate to Components > Virtuemart and then click ADMIN > USERS

    That user is not listed.
    (Please see screen3.png attached > http://www.skynetdigital.com.au/screen3.png)

    I believe if I disable this module and overright the files that came with it to the original ones when I installed Virtumart / joomla this will fix it.

    However I could be completly wrong and it is something unrelated.

    please help

    Thanks.
  • Default avatar
    digicloud    
     4 years ago
    0

    just to add to my previous post, I am willing to pay someone to fix this for I need this issue resolved within the next 3 days. Please contact me via sales@skynetdigital.com.au, odesk.com and or paypal for payment.

    Thanks.
  • Your avatar
    seyi    
     4 years ago
    0

    Hello,

    The only time AwoCoupon code comes into play in the front end is when the customer enters a coupon code and hits the apply button. Other than that, your shop should run normally.

    I have seen such a problem before, and the most likely reason is your database is out of sync with your userfields. Yes the user is first added to Joomla and then Virtuemart tries to add the user as a virtuemart user. In doing so, it looks at all the user fields configured in your backend, which should correspond with columns in your vm user table, and adds the information. If a column is missing in your table, then there will be a mysql error, causing the user to never be added, in turn leading to errors in the front end.