Upgrade from AwoCoupon free to Pro version - SQL and PHP problem


  • Your avatar
    seyi    
     6 years ago
    0

    Hello

    I have just upgraded from the free version to the pro version and installed the update on my live site. I did this by installing the com_awocoupon-PRO-1.2.2 and I also installed, plug_acymailing_awocoupon-1.0.0.

    I then did the install check and upgraded all the Virtuemart files with no problem.

    There are quite a few customisations that have been done on my site, but some have been done before I took over the site as well.

    The problem(s) I am getting are as follows:

    When trying to view my old coupons:

    Warning: Invalid argument supplied for foreach() in........./administrator/components/com_awocoupon/models/coupons.php on line 57
    Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in..........libraries/joomla/database/database/mysql.php on line 342

    Below the search section on the coupon page:

    Warning: Invalid argument supplied for foreach() in ............administrator/components/com_awocoupon/views/coupons/tmpl/default.php on line 56

    I tried to fix this by using this post: http://awodev.com/forum/awocoupon/help-section/history-uses-not-working

    but the collations don't seem to be the problem.

    I also get the following error when trying to create a new coupon:

    DB function failed with error number 1054
    Unknown column 'function_type2' in 'field list' SQL=INSERT INTO `jos_awocoupon` ( `id`,`coupon_code`,`coupon_value_type`,`coupon_value`,`function_type`,`function_type2`,`discount_type`,`user_type`,`function_type2_mode`,`published` ) VALUES ( '0','TestCoupon','percent','5','coupon','product','overall','user','include','1' )

    I am running on Joomla v1.5.7 and VM 1.1.2 - the free version was working fine, but I also need to try and keep the data from this version as I have distributed the coupon codes and I need the reporting data on the codes as well.

    Regards
    Petros

  • Your avatar
    seyi    
     6 years ago
    0

    Hello Petros,

    It looks like the upgrade of jos_awocoupon table in the db was not done. We will need to manually update it. I will send you a script to run on the db.

  • Default avatar
    ricardo    
     5 years ago
    0

    Trying to fix other problem i´ve deleted mysql tables from awocoupun but when i reinstall the component it doesnt create the database again.
  • Your avatar
    seyi    
     5 years ago
    0

    you can install the database tables manually.

    Look at www/administrator/components/com_awocoupon/install.mysql.sql, change #_ to your prefix, generally jos, and run it in your database.

    Let me know if this works.