Unique issue, VM 1.2b with Joomla 2.5


  • Default avatar
    charles4    
     3 years ago
    0

    Hi guys, I have a Joomla 2.5 site that is running an updated version of VM 1.1.9 called VM 1.2b. It is a special version of Virtuemart that is jusy like 1.1.9, but runs on Joomla 2.5.

    I installed the AWO coupon version 2.0, but it won't even open in the backend - just gives me a blank page. Can you tell me if it is due to the VM1..2, or is it a glitch in the program? live site: http://vbandp.com, I can give you FTP and Admin access through email.
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    That is a problem.

    AwoCoupon 1 is developed for Joomla 1.5, Virtuemart 1.1.x
    AwoCoupon 2 is developed for Joomla 1.5/2.5/3, Virtuemart 2.x

    There is no compatibility for your version. If you must get this to work, the best solution would be to install AwoCoupon 1 and update it to work with Joomla 2.5, but that is alot of work.
  • Default avatar
    charles4    
     3 years ago
    0

    So the program won't even open if VM 2.0 is not loaded in the site? I installed the 2.0 version, but when I open it in the back end, it just shows a Blank page. I will rewrite the 1.0 to work with J25 if I have to, I was hoping to actually rewrite the 2.0 version to work with VM 1.2. The VM 1.2 version is a really great alternative to upgrading to VM 2.0, if we could collaborate on this I am sure you will be able to sell it to others who are using this version.
  • Your avatar
    seyi    
     3 years ago
    0

    Yes, I think you are right, it would be better to use AwoCoupon 2.x and update that to work with VM 1.2. I have no time to do this, but can help in any problems you have. Contact me directly by email, using the email on the contact us page with any questions you have.
  • Default avatar
    charles4    
     3 years ago
    0

    What email should I send to?

    The first issue is that the 2.0 won’t even load in the new J25 platform. Could the old data from the old database import be causing it to be blank?

    I could erase all the AWO coupon fields first, then see if a fresh install works. Then I can work on the framework to allow VM 1.2b to work, then import the database tables. Does that sound like a plan?
  • Your avatar
    seyi    
     3 years ago
    0

    just sent you a private message.
  • Default avatar
    rogrog    
     3 years ago
    0

    Hi Seyi / Charles4,

    Did you have any luck with VM 1.2? My client desperately needs AwoCoupon Pro functionality and wanted to confirm if any progress had been made?

    (Currently we are using free AwoCoupon 1 on VM1.2, with a couple of rough hacks to get it basically (but not fully) working).

    Thanks
    -rogrog
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    I do not believe there was any traction on this project.
  • Default avatar
    alexandra8    
     3 years ago
    0

    Hi Seyi,

    We have purchased AWO Coupon Pro 1.x for use with virtuemart 1.2 on Joomla 2.5 in the hopes that at least basic functionality could be simply achieved.

    The trick used for the free version of this plugin (simply hard coding some of the filepaths in admin.awocoupon.php) no longer seems to work in the pro version.

    Could you please provide some pointers as to how functionality could be achieved? (Though I have a good web dev / php understanding, I am new to Joomla plugin development - especially the differences between joomla 1.5 & 2.5 functionality).

    Thanks, Will
    (also the user RogRog above).
  • Default avatar
    charles4    
     3 years ago
    0

    I could still really need this, and it seems that it may be getting some traction. Could we look at writing this, I would be willing to Beta test it and make some adjustments along with some other programmers. Let's pull together and see what we can come up with!
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    Looking into this. Will update shortly.
  • Your avatar
    seyi    
     3 years ago
    0

    Just updated AwoCoupon to the lates, 2.2.1, and this supports Virtuemart 1.2.x and Virtuemart 1.1.x, since they share the same base code. So download the latest to test it out. Not sure everything will function well, but at least 90%.
  • Default avatar
    alexandra8    
     3 years ago
    0

    Hi Seyi,

    It appears there is one major issue - at the ned of the checkout process (after confirming order) the following errors occur.

    Warning: require_once(/home/frenchna/public_html/administrator/components/com_awocoupon/assets/virtuemart/ps_coupon_remove.php) [function.require-once]: failed to open stream: No such file or directory in /home/frenchna/public_html/administrator/components/com_virtuemart/classes/ps_coupon.php on line 141

    Fatal error: require_once() [function.require]: Failed opening required '/home/frenchna/public_html/administrator/components/com_awocoupon/assets/virtuemart/ps_coupon_remove.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/frenchna/public_html/administrator/components/com_virtuemart/classes/ps_coupon.php on line 141

    Thanks
    Will
  • Your avatar
    seyi    
     3 years ago
    0

    Hi Will,

    Thats remnants of AwoCoupon 1. You should upload an unedited ps_coupon.php file again and then go to awocoupon->installation and install the core.