Total value sended to Pagseguro is wrong after use Coupon Discount


  • Default avatar
    pcdiniz    
     4 years ago
    0

    I am using the plugin pagseguro from Brasil to checkout in my webstore, I am using to the last version of the AwoCoupon and AwoAfilliates.

    When I insert the Coupon code are everythink ok, but when I make a checkout, the value sended to pagseguro don´t have discount.

    Anybody can help with it?

    My website is: www.iboxonline.com.br

    Thank you

    Paulo
  • Your avatar
    seyi    
     4 years ago
    0

    Hello,

    Is pagseguro your payment processor? If so can you test it with paypal to see if the discount is sent? If so then there must be a problem with the pagseguro payment processor.
  • Default avatar
    pcdiniz    
     4 years ago
    0

    The Pagseguro is my payment processor yeat, but I can´t to fix it.

    I don´t know what is the problem because if i am use the original VM Discount Coupon it´s work perfectly.

    Any body can help me?

    Thank you
  • Your avatar
    seyi    
     4 years ago
    0

    Certainly, do you have a copy of this payment processor? Or if you prefer can you send me, through private message, temporary admin and ftp access to your account and I can investigate the problem.
  • Your avatar
    seyi    
     4 years ago
    0

    Hello,

    I have taken a look and it is now fixed. The main problem is the payment system is calling the cart session, which at this point is not reliable. Commenting this code out and calling the actual order in the database fixed it.
  • Default avatar
    pcdiniz    
     4 years ago
    0

    Thank you so much.

    I have tested and are working perfectly now.

    Paulo