Specific product coupon problem


  • Your avatar
    seyi    
     4 years ago
    0

    I created a coupon specific to a single product as a model of e-mail plugin, but copies of the Code for each registration does not keep records of the selected product, ie, this coupon can be used to buy any product. Am I wrong or is there a configuration problem with the plugin?

    Function Type: coupon
    Percent or Amount: Percent
    Discount Type: Specific
    Value: 100
    Number of Uses: Per Customer 1
    Minimum Value: 0

    Customers: no selection
    Products: its a PUB version of a book, it's a child of a father product

    I`m using the free version until I see the basic functions in perfect condition.

    Tks
  • Your avatar
    seyi    
     4 years ago
    0

    thanks for catching the error. It is now fixed, download the latest free version, 2.0.4.
  • Default avatar
    Tiago    
     4 years ago
    0

    Hello there,

    I'm still having the same problem, even after downloading the latest version.

    Looking forward to your reply,

    Thanks
  • Default avatar
    anaffelici    
     4 years ago
    0

    Component working perfectly! Congratulations Seyi, for the quality of the product, the prompt return of the support. I'll buy the pro version in the second phase of the campaign. And always will indicate your store.

    Thank you.
  • Your avatar
    seyi    
     4 years ago
    0

    in the admin section, go to extensions manager->manage->filter by 'awo' and verify your version of awocoupon is 2.0.4.
  • Default avatar
    Tiago    
     4 years ago
    0

    I have checked and the version is 2.0.4.
  • Your avatar
    seyi    
     4 years ago
    0

    strange. Just to be sure, you have a coupon template entered in awocoupon email which has a specific product. And when a coupon is generated the specific product is not attached to the new coupon? and you are using joomla 2.5 with AwoCoupon Email with AwoCoupon Free 2.0.4? If this is the case and you are still having the problem, you will need to look at the file that caused the problem in the first place. in
    www/administrator/components/com_awocoupon/helpers/plgautogenerate.php, around line 81 should be this:
    <?php
                $sql 
    'INSERT INTO #__'.$table.' ( coupon_id,'.$column.' ) VALUES '.substr($insert_str,0,-1);
                
    $db->setQuery($sql);
                
    $db->query($sql);
    ?>

  • Default avatar
    Tiago    
     4 years ago
    0

    I'm only using AwoCoupon Free, I don't have AweCoupon Email. When I try to create a new coupon and make it "Specific", I save it, and then it will be set to "overall" as if it ignored my decision.

    I checked that file and that line, the code is the same.
  • Your avatar
    seyi    
     4 years ago
    0

    that is a different problem from this thread. :)
    I cannot reproduce it, maybe it is browser specific, what browser are you using?

    Also did you select a specific product? If not, assuming a javascript error message failure, the discount would default back to overall.

  • Default avatar
    Tiago    
     4 years ago
    0

    Ah okay, sorry, I read the post content fast and didn't notice it. Sorry :)

    I'm using Chrome 19, Windows 7 x64.

    I selected a specific product, yes. I didn't get any javascript error message
  • Your avatar
    seyi    
     4 years ago
    0

    I cannot reproduce this. can you pm me temporary admin access to take a look?