Shopping Cart Not Emptying If Paying in Full with Coupon


  • Default avatar
    bniceaa    
     4 years ago
    0

    After using a coupon to pay for 100% of item, the shopping cart does not empty.

    Meaning if you use a coupon code for 100% of price (so item is free), the shopping cart should be empty after checkout.

    However, it is still saying X ITEMS in cart.

    For example, if you add $25 gift card to cart... and then purchase. It should be empty after, however, it still says $25 in cart.

    I tested this using virtuemart internal coupon and shopping cart empties.
  • Your avatar
    seyi    
     4 years ago
    0

    Im using Virtuemart 2.0.8, AwoCoupon 2.1.0 and cannot reproduce. I use a gift certificate to make the cart 0 and after confirm, the session is emptied. What versions are you using?
  • Default avatar
    bniceaa    
     4 years ago
    0

    Virtuemart 2.0.10 and AWO 2.1

    After I use a coupon for 100%, I get "Thank you for your order!

    Your order has been processed."

    however, the cart still shows the items within it.
  • Your avatar
    seyi    
     4 years ago
    0

    I have tried it with Virtuemart 2.0.10 and AwoCoupon 2.1.0 and the same results, after confirming and getting the thank you page, the cart session is emptied. Not sure what you are using, but maybe you can try it with default virtuemart template? If you are using some type of one page checkout, disable it.
  • Default avatar
    socialsteam    
     11 months ago
    0

    I'm having exact same problem as original poster, J!3 latest, VM3 latest, OPC from Rupostel, Reviver theme.
    When i use an AWO gift certificate to pay for the entire order, the order completes just fine and sends receipts etc. But the cart does not empty its contents. Even though the order is fine, the customer is confused and would cause duplicate orders and customer service nightmare.

    Please help if you can,
    Thanks
    :)
  • Your avatar
    seyi    
     11 months ago
    0

    Hello,

    Try disabling opc and using the default virtuemart cart. Do you get the same issue? If not, then there is something in OPC keeping the order open.