"Save" button doesn't work when I introduce coupon


  • Default avatar
    webmarketing    
     a year ago
    0

    Dear AwoDev Support Team:

    I downloaded Awo Couopn Free version yesterday, and I have the same problem I have found here: http://awodev.com/forum/awocoupon/help-section/awo-coupons-pro-does-not-work, but that solution you gave doesn't work for me.

    Backend works fine, but in the very last moment when I introduce the cupon before buying and I click on "Save" button, nothing happens as if the button doesn't work at all.

    My Virtuemart version is 2.6.6 and awocupon la 2.0.17.

    I have tried the component in this test-website: http://copiaentreno-cp89.webjoomla.es/tienda

    I can give you admin rights if you need to solve the issue

    I appreciate your support. Thanks in advance!
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    The problem you are having is a virtuemart problem and regardless of if you have AwoCoupon installed or any other coupon plugins you would still receive it.

    There is a submit button to submit a coupon, but the problem is there is no form around this button. The only fix I know of to fix this is this is to update the template in virtuemart.

    To fix find the file:
    www/components/com_virtuemart/views/cart/tmpl/default_coupon.php

    Copy it to your template if it is not already there:
    www/templates/[your_template]/html/com_virtuemart/cart/default_coupon.php

    Then alter it to display the form. In 2 places you should see

    if ($this->layoutName!='default') {


    Change it to

    if (1==1) {


    That should add the form in the front end allowing the coupon code to be processed when submitted.
  • Default avatar
    webmarketing    
     a year ago
    0

    Thank you very much for your reply. I have followed your steps but it doesn't work. It seems that you can click the button now, but there is no result.
    Is there any other chance?
    Thank you again. Best regards.
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    Just checked the site. The coupon button is still not within a form. You should verify the changes, try changing to the default virtuemart template to see if that makes a difference.