Problem with CSV import and export


  • Your avatar
    seyi    
     5 years ago
    0

    Hi, can you supply a valid .csv file?

    When I try to import using my self-created csv file, I get the following error for each coupon code:
    -- That coupon code already exists. Please try again (this is not true, coupon don't exist)
    -- Not enough columns to process (in my csv I am using columns a - u)

    When I try to export a report to get a valid csv file, I get just 1 cell filled with "~ID,"Coupon Code","Published","Function Type","Function Type 2","Percent or Amount","Discount Type","

    Regards
  • Your avatar
    seyi    
     5 years ago
    0

    As long as you have some coupons in your coupons list, go to reports->coupon list and export to excel. That report is a valid csv import, as long as you change the coupon codes.
  • Default avatar
    peter49    
     5 years ago
    0

    I'm afraid this doesn't work. I have valid coupons but when I export a list, all I get is 1 single cell filled with the following code:
    "~ID","Coupon Code","Published","Function Type","Function Type 2","Percent or Amount","Discount Type"," "br / span style="

    Can you send me an example csv file that I can use?
  • Your avatar
    seyi    
     5 years ago
    0

    Sorry, did not read your original post carefully enough.

    What language are you using to export/import?
  • Default avatar
    peter49    
     5 years ago
    0

    The admin language is set to English, the site language to Dutch.
  • Default avatar
    peter49    
     5 years ago
    0

    Hey I set the default site language to English and now my coupons are exported.
  • Your avatar
    seyi    
     5 years ago
    0

    so i'm confused. did you have your admin language set to english or something else?

    There is definitely a problem with the coupon list report when the language is set to german and a problem with importing also. These 2 issues will be fixed in the next release.
  • Default avatar
    peter49    
     5 years ago
    0

    First I had the admin language set to english and the site language to Dutch. Then I could not export the coupons.

    Now I have both the admin language and the site language set to english and now the export function works. However, the output is a comma seperated file which cannot be read by excel or another csv editor. Which editor do you recommend to edit the csv file?
  • Your avatar
    seyi    
     5 years ago
    0

    I use excel. I think it is a regional setting, depending on your region from reading this post:
    http://www.ozgrid.com/forum/showthread.php?t=134498&page=1

    It is possible to change the delimiter but requires updating the code.
  • Default avatar
    peter49    
     5 years ago
    0

    Hi, changing the regional settings did not work for me. But I got it working now, here's what I did.
    - create csv file in excel
    - in notepad: search/replace delimiter ; to , (this still gives no working file, error: "No ID specified")
    - open/save in CSVed (= free csv editor), apparently this corrects the strings
    - import in awocoupon
    - done

    When I use Notepad to compare the .csv file before/after saving it in CSVed, I see no difference. But the 'converted' file works, the other not.

    Anyway, quite a workaround but it works ... Note that I have left both the administrator language and site language to Dutch and the new import worked anyway.
  • Your avatar
    seyi    
     5 years ago
    0

    Yes it is. In the next release, you will be able to select your delimiter on the configuration screen.
  • Your avatar
    seyi    
     5 years ago
    0

    you can now set the delimiter in version 1.4.0. It is also possible to import in all languages supported.