Prestashop - Oops, something went wrong - Shipping?


  • Default avatar
    kent73    
     3 years ago
    0

    First of all, this is a great module. Thanks...It actually works, which is not always the case with Pretashop modules.

    Now, the problem:

    I can redeem a coupon at Step 1 of my shopping cart. This works well.

    The problem occurs when I reach the payment stage.

    1. When I click "make a payment", the system craps out, I get a blank page and everything is erased from my cart when I go back.

    2. As well, if the certificate is worth more than the value of my order, I am still prompted to choose a carrier at Step 4 of the payment process and when I try to go to the next screen I get the "Oops, something went wrong".

    I turned on the default theme to test this and the problem persists regardless of theme.

    I am using Prestashop 1.5.4 and I just bought the module this week.

    I assume that I am not the first person to have this problem? What is the fix?

    Thanks for any help.
  • Default avatar
    benjamin    
     3 years ago
    0

    Did you try using the one page checkout system? I've using that and don't have any issues.

    Plus the problem could be with your theme. Try disabling awocoupon and just using the standard cart rules coupon. If that does not work then your problem is with the theme.
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    Those are both strange errors you are having. Are these errors both happening when you are using (not purchasing) a gift certificate?

    By 'make payment' is this when you are confirming the order or just selecting the payment method?

    If is possible to get temporary admin access to have a look at the problem directly?
  • Default avatar
    kent73    
     3 years ago
    0

    Hello Seyi,

    Yes they are strange errors when I am using a certificate.

    If the order total is $0 (the certificate is worth more than the order) it breaks when I am confirming the order.

    If the order total is greater than $0, it breaks when I try to pay.

    I would be happy to give you admin access if you have time to look. Where can I send that information?

    Thanks,
    Kent
  • Default avatar
    kent73    
     3 years ago
    0

    Hi Benjamin, I cannot use one page checkout, but good idea to to try standard coupons. Thanks.
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    You can send me a private message. Link directly to the left.

    If you can please also include temporary ftp access so I can debug the problem.
  • Your avatar
    seyi    
     3 years ago
    0

    Ok, took a look. I am no prestashop expert so this took forever to find, but was actually quite a simple problem. It was the overrides.

    I eventually looked in www/cache/class_index.php and see this line:
    'Order' => 'override/classes/sideroad/Order.php',

    Normally, if there is an override, it would be this:
    'Order' => 'override/classes/order/Order.php',

    And that is exactly where the AwoCoupon override is. So I copied the AwoCoupon override, made the minor adjustments and tested. It works now.
  • Default avatar
    kent73    
     3 years ago
    0

    First of all, let me reiterate that this is a great module. It works well and I am very impressed by it.

    Second of all, thank you for looking into this. I was not expecting such great support. I will definietly recommend this module on the Prestashop forums.

    Thanks again.
  • Your avatar
    seyi    
     3 years ago
    0

    You are welcome, and thanks for the raving review in the Prestashop forums :)