Prestashop Gift Certificates won't work


  • Default avatar
    cristiano    
     10 months ago  last edited 10 months ago
    0

    test made with a clean install of Prestashop 1.5.6.0 with Awocoupon PRO 1.2.3



    step to reproduce:


    • create a product with 3 text customization field (email, name, text), than set the name "gift card", price, quantity and save.

    • in awocoupon->Coupons, add new one as follows:
    1. Coupon Code: dhkgDUx2bHK (or whatever)
    2. Published: -2 (template)
    3. Function Type: Gift Certificate
    4. Percent or Amount: Amount
    5. Value: 10.00000
    6. Exclude: Gift Products

    • in awocoupon->Tools->Add new gift certificate product as follows:
    1. product: gift card
    2. template: dhkgDUx2bHK (or whichever you previosly created)
    3. image: christmast
    4. published: published
    5. expiration: blank
    6. vendor name: vendorrname
    7. vendor email: vendor@email.com
    8. Recipient Name ID: 2 (according to the ps_customization_field table)
    9. Recipient Email ID: 1 (according to the ps_customization_field table)
    10. Recipient Message ID: 3 (according to the ps_customization_field table)

    • in awocoupon->configuration->gift certificate enable: "activate vendor email" and set subject and body, than save.

    • Log into the frontend as a customer, go to the "gift card" prouct page, set the customization fields with email, name and text of the person you want to recive the mail with the generated code. save and add it to the cart than buy it.

    As I understood reading the documentation, with this set up everyone should recive a mail: the customer, the person that is reciving the gift specified by the customer, and the vendor. Then the coupon generated and sent by mail could be used.

    But actually, none of that is happening. Of course the shop mail is fully functional. but only the order confirmation mail is sent.

    In the history of uses of the gift certificate there is an entry, but checking from the report page, it has no customer/order data associated, and the "purchased gift certificate list" is empty.

    Am I doing something wrong?

  • Your avatar
    seyi    
     10 months ago
    0

    Hello,

    Has the order gone through the 'payment accepted' stage?
  • Default avatar
    cristiano    
     10 months ago
    0

    Sure, I manually changed status  to the order several times, of course triyng first with "payment accepted"

  • Your avatar
    seyi    
     10 months ago
    0

    Hello,

    Really not sure.  Is it possible to send temp admin access via private message to have a direct look?
  • Default avatar
    cristiano    
     10 months ago
    0

    Well, actually the environment I'm testing on is at localhost. Have you had  any troubles in reproducing the problem? ...'cause I tested on those original and unmodified versions so that could be fast and easy to reproduce. I could find out a way to use some webspace somewere in a couple of days, but actually I don't have a free machine to put this on.
  • Your avatar
    seyi    
     10 months ago
    0

    Hello,

    I dont know how I missed it but just realizing the version of AwoCoupon you are using, 1.2.3.  This is a very old version and really no way to know what the issue is here.  This version does not even use the Prestashop email system, which might actually be the problem.  That was added in 1.2.5.  I think the first thing you should do is upgrade to the latest.  Here are the release notes:

    http://awodev.com/documentation/awocoupon-pro/release-notes#doctab2

    Prestashop tab