php errors after installing AwoCoupon-Pro-2


  • Default avatar
    FirstDegreeGolfAcademy    
     a year ago
    0

    Hi

    I have installed com_awocoupon-PRO-2.3.4.zip to a site running joomla 1.5.26 with virtuemart 1.1.9 and when I try to access the component I see only php errors. I then installed the free version and that works fine. What are the server requirements for this to run correctly?

    Thanks,
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    It just requires php 5. Should work fine with Joomla 1.5 and Virtuemart 1.1.9. Can you tell me what error you were seeing?
  • Default avatar
    FirstDegreeGolfAcademy    
     a year ago
    0

    Hi

    When I install I am seeing:

    Database Tables Installation: Successful
    Fatal error: Access level to AwoCouponModel::_getList() must be public (as in class JModel) in /home/edwar28/public_html/administrator/components/com_awocoupon/helpers/awocouponModel.php on line 22

    on a white screen. Then when I try to access the component I see:

    Fatal error: Access level to AwoCouponModel::_getList() must be public (as in class JModel) in /home/edwar28/public_html/administrator/components/com_awocoupon/helpers/awocouponModel.php on line 22

    on a white screen. So the only option then is to uninstall at which point I see:

    JInstaller::install: Error! Could not find a Joomla! XML setup file in the package.
    If this Extension has created tables or installed additional files, they must be removed manually.

    Uninstall Component Error

    The free version does install without errors and does work. Please advise.

    Thanks,
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    What version of php is this?

    That error you are receiving can be fixed by altering:
    /home/edwar28/public_html/administrator/components/com_awocoupon/helpers/awocouponModel.php on line 74 is
    <?php
        
    protected function _getList($query$limitstart 0$limit 0) {
    ?>


    Change it to
    <?php
        
    public function _getList($query$limitstart 0$limit 0) {
    ?>

  • Default avatar
    FirstDegreeGolfAcademy    
     a year ago
    0

    Hi

    The version of PHP on the server is 5.4.27.

    Editing that file seems to have worked however I cannot get the license code to activate. When I try I get: Error Activating License. Please advise.

    Thanks
  • Your avatar
    seyi    
     a year ago
    0

    Sending you a private message.
  • Default avatar
    mike40    
     a year ago
    0

    Hi, just installed version 2 over 1 using upload. Getting same issue so followed change to 'home/edwar28/public_html/administrator/components/com_awocoupon/helpers/awocouponModel.php on line 74'

    I tried this an now get error: Fatal error: Class 'AwoCouponView' not found in /home/web/public_html/administrator/components/com_awocoupon/views/dashboard/view.html.php on line 11

    How do I fix this from here.

    Thanks in advance,

    Mike
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    Are you going from AwoCoupon 1.x pro to AwoCoupon 2.x pro? It requires a manual install. Do you have a backup of your AwoCoupon tables?
  • Default avatar
    mike40    
     a year ago
    0

    Hi Seyi,

    Thanks for your message. Yes, upgrading from AwoCoupon 1.x pro to AwoCoupon 2.x pro (Just purchased). No I did not backup the tables as there weren't many coupons and thought it would be good time to upgrade. Do I de-install and re-install? Would this work? Thanks in advance. Mike
  • Your avatar
    seyi    
     a year ago
    0

    Hello Mike,

    Yes, I would uninstall AwoCoupon. Then just check the database and make sure all #__awocoupon tables are deleted. If not manually delete them and then run the installation again.
  • Default avatar
    mike40    
     a year ago
    0

    Hi Seyi,

    Thanks for that...Yes, just tried to de-install and now I get: Fatal error: Class 'AwoCouponModel' not found in web/public_html/administrator/components/com_awocoupon/models/installation.php on line 11. Unfortunately, I cannot run or de-install the component. Sorry for all the issues. Just like to get it running. Thanks M
  • Your avatar
    seyi    
     a year ago
    0

    hello,

    can you send me a private mesage with temp admin and ftp access to look at it? Can get it installed and running quickly.