Permanent coupon not working


  • Your avatar
    seyi    
     5 years ago
    0

    I am using 1.5.23 and VirtueMart 1.1.9

    We have gift certificate products set up using AwoCoupon which are working as well as a couple of one-off gift certificates through AwoCoupon which are also working.

    I have set up a permanent coupon using AwoCoupon for $10.00 but it is not working.

    After submitting code it just displays text:

    Coupon code not found. Please try again.
    If you have a coupon code, please enter it below: etc.

    You can try using SV1001 at www.enjoydinner.com.au to see for yourself.

    You can also try coupon "TEST". This is permanent coupon setup via VirtueMart Coupon.

    So I am not sure whether this is an AwoCoupon issue or VirtueMart issue.

    Any help you could provide would be greatly appreciated! My client really needs to be able to use the permanent coupon.
  • Default avatar
    jillian    
     5 years ago
    0

    Should have mentioned that the AwoCoupon SV1001 is setup as 1 per customer for all customers for all products.

    Is there a rule that this type of coupon won't work until you have logged in at checkout? i.e. I have now tried it again - it still does not work from the cart, but after I registered as a new customer it did work.
  • Your avatar
    seyi    
     5 years ago
    0

    Coupons setup as
    - x per customer
    - select specific customers
    - select specific shopper groups

    All require the user to log in to verify that they qualify.

    Also answered your original question on virtuemart forum:
    http://forum.virtuemart.net/index.php?topic=81635.msg303649#msg303649
  • Default avatar
    jillian    
     5 years ago
    0

    Seyi- thanks for that clarification.

    That being the case - can you suggest the best way to remove the option to enter a coupon from the cart (that is, before the customer has logged in or registered)? Do you need to edit a .php file?
  • Your avatar
    seyi    
     5 years ago
    0

    http://awodev.com/forum/awocoupon/help-section/it-possible-have-code-used-set-number-times-without-users-lo#comment-46