Parse error: syntax error, unexpected T_STRING [SOLVED]


  • Default avatar
    wpost    
     3 years ago
    0

    I have been retained to take over a site using AwoCoupon Pro 2.1.1 on Virtuemart 2.0.8e, Joomla 2.5.9, and PHP 5.3.21. In the Joomla backend the AvoCoupon control panel displays fine, but attempting to view any link from it (Coupons, Gift Certificates, Profiles, etc.) takes me to a blank page.

    Searching this forum I found this good advice...

    http://awodev.com/forum/awocoupon/help-section/blank-page-edit-gift-certs

    ...to uncomment error reporting in admin.awocoupon.php. Doing that, instead of a blank page I now see "Parse error: syntax error, unexpected T_STRING in /home/shopcopa/public_html/administrator/components/com_awocoupon/models/license.php on line 1". Examining the cited file I see that it's one long (ca. 9000 chars) line that begins as php files normally do, but does not have the expected php closing.

    I have migrated the site to a new server, but this problem predates the migration and was present on the old server before I began.

    I suspect it is unrelated, but the temporary license has expired. I have asked the original developer to make the license permanent and provide me with the local key. But of course when he does I won't be able to activate it until I get the blank screen problem fixed.

    I am aware that I have an old version installed, and will update as soon as I get the license made permanent.

    What should I try next to resolve this issue?

    Many thanks,
    Warren
  • Your avatar
    seyi    
     3 years ago
    0

    Hello Warren,

    I would try reuploading the license.php file. The file itself might be corrupt causing problems.
  • Default avatar
    wpost    
     3 years ago
    0

    Agreed. Since I am not the purchaser, I'll ask the purchaser to provide me with the original license.php. Or he could download for me the latest stable version of AwoCoupon and I could install it atop my current installation, hopefully solving both the corrupt license.php and bringing me up to date in one go.

    I'll report back; many thanks.
  • Default avatar
    wpost    
     3 years ago
    0

    Upgrading to 2.1.7 resolved the issue. Many thanks!
  • Your avatar
    seyi    
     3 years ago
    0

    Good to hear, you are welcome.