No Facebook Rules are available + Error 500: The file facebook.xml could not be found + Language Problems


  • Default avatar
    moti79    
     a year ago
    0

    Hey there!

    We bought the AWO coupon pro and Rewards
    We're having various problems with setting up the coupons and facebook rules,

    1) I have absolutely no rules with facebook to setup!
    2) Facebooki Plugin has this error
    Error 500: The file facebook.xml could not be found
    https://drive.google.com/a/artbit.co.il/file/d/0B9f3V3VJ98WNR0VCTmxoeGFLNWM/view?usp=drivesdk
    3) Language issues - when setting up any template or any text for that matter in the site native language (hebrew) all the hebrew text in the profile and email template turns to question marks. so it kind of looks like this "Mycuties.co.il ??????????????"

    your help is kindly needed!
    Thanks in advance!

    Joe
  • Default avatar
    moti79    
     a year ago
    0

    i also noticed now that in the external API's the twitter / facebook sections have disappeared now!
    please help!
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    Ok, one problem at a time. So facebook/twitter, if using the latest, have both been moved into plugins. So on aworewards -> dashboard, you should see a list of plugins on the right side, and their status. If facebook/twitter are not published you can publish them there, then you will see the option when creating a rule.
  • Default avatar
    moti79    
     a year ago
    0

    Hey there!
    I think all the issues are part of the same problem
    As for the cofiguration - we're not this lame :-)

    The plugins are on -
    https://drive.google.com/a/artbit.co.il/file/d/0B9f3V3VJ98WNRkI0SmcwUE1sZVE/view?usp=drivesdk

    and when you go to the config - this is what i have -
    https://drive.google.com/a/artbit.co.il/file/d/0B9f3V3VJ98WNOU8tRHlsYnRwdzQ/view?usp=drivesdk

    and when i go to the plugins - they are on.
    https://drive.google.com/a/artbit.co.il/file/d/0B9f3V3VJ98WNMUNnbExqVzRHeWc/view?usp=drivesdk
    click on the facebook plugin - all i see is this error.
    https://drive.google.com/a/artbit.co.il/file/d/0B9f3V3VJ98WNS3RZVi1QX3d6LVE/view?usp=drivesdk
    disabling the plugins doesn't bring back the fields to the configurations...


    it appears there's some file missing (facebook.xml), maybe you can send this to us via email - and also tell me where to install this manually via FTP or something,

    Thanks!



  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    Start by going to extensions->extensions manager->manage, search for both the twitter and facebook plugins and uninstall them.

    Then go back to aworewards dashboard, you should now see an 'install' link for the 2 plugins. Install them and try the config again.
  • Default avatar
    moti79    
     a year ago
    0

    Hey Seyi!

    I uninstalled and re-installed the plugins, now i have the fields available again in the backend - however, it will not save anything...
    when going into the plugin itself from the plugin manager i still get the error:
    500 The file facebook.xml could not be found.

    please help!
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    go to global configuration and set debug mode to yes, and then try to resave. Do you see any database errors? If not, then I really do not know what is going on but happy to debug it directly if you can send a private message with temp admin and ftp access.

    The plugin not opening is a small error that will be fixed next version, but should not affect it working.