No email received and the coupon is not active??


  • Default avatar
    work    
     a year ago
    0

    I don't know what is wrong. But I did a purchase with Eshop and while I received Eshops order I never got the email with the coupon (Gift Certificate) and when I look at the list of coupons, it shows 1 total coupons and 0 active coupons.

    Here was my steps.
    I created a new Eshop product called "$50 Gift Certificate" (valued $50)
    In AwoCoupon I

    a) Created a new profile
    b) Created a new coupon including setting it as a "template", value $50 and added "$50 Gift Certificate" (created in Eshop) as a product asset.
    c) Finally I created a new Gift Certificate Product including selecting the $50 Gift Certificate as the product, base price (Price Calculation Type) , selected my only profile image I have and saved.

    I then placed an order for the eshop product I created "$50 Gift Certificate" and successfully checked out.

    Please help. Seems like a lot of steps to have a simple $50 Gift Certificate.
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    For b), you do not want to add the gift certificate as the asset. Otherwise the generated gift certificate will only work for purchasing the $50 gift certificate.

    For the profile created, did you add any email content? Having a blank email will cause it no to send.

    In awocoupon->installation, is the required items installed?

    In AwoCopon->configuration->gift certificate screen, there is a debug mode. If you set it to yes, then it will log the last gift certificate order it processes. The information there might help figure out why it is not working.
  • Default avatar
    work    
     a year ago
    0

    Its still not working after I removed the product as an asset and I even turned on debug. Please help
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    If you can send me a private message with temp admin access I can have a look.
  • Your avatar
    seyi    
     a year ago
    0

    Thanks for the access.

    Found the problem, in awocoupon->configuration->gift certificate tab, the order status for sending automatic email was set to cancelled. I have changed it to confirm. Then updated one of your orders from confirmed->pending->confirmed. The gift certificate was triggered and can be seen in awocoupon->history of uses->orders page.
  • Default avatar
    work    
     a year ago
    0

    Thank you so much. I got the email and it works!
  • Default avatar
    work    
     a year ago
    0

    Just one more issue. When I go to index.php?option=com_awocoupon&view=giftcerts to see my balance. I get "No records found."

  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    The balance is not automatically loaded with purchased gift certificates. The customer can load it manually, or if using a gift certificate in the cart where there is a balance, and you have the option enabled, then it will be loaded.

    Here is just a little on how the balance works:
    http://awodev.com/blog/awocoupon-gift-certificate-balance
  • Default avatar
    work    
     a year ago
    0

    Oh right. I apologize. It would not make sense for the buyer to buy a Gift Certificate to only be on their own balance. They may wish to give it to someone else to use on the site. Thank for answering this question.