no coupons send to customers


  • Default avatar
    pyrrus    
     11 months ago
    0

    Hi there,
    using VM 3.0.11.4 and Joomla 3.4.6 with latest version of AWOcouponPro.
    Configured coupon products for selling in virtuemart but no coupons created or send to customers.

    The plugins are all activated

    Any idea?
  • Your avatar
    seyi    
     11 months ago
    0

    Hello,

    Have you reviewed some of the common issues dealing with selling gift certificates?
    http://awodev.com/documentation/frequently-asked-questions#giftcert-autoproblem

    Also if still not working, in awocoupon->configuration->gift certificate, there is a debug button which you can set to yes. Then process another order, from pending to confirmed, to trigger the gift certificate, and then look in the debug to see where it stops.
  • Default avatar
    neil81    
     11 months ago
    0

    I'm also having this problem.

    I'm creating Gift Certificates, using Hikashop. The certificate order is created, AwoCoupon does show the order and that the GC code is created, but no emails are being sent out.

    I did check the Troubleshooting Tips, and verified that all proper fields are filled out. I also turned on the debug for GC, but after processing an order to confirmed, nothing appeared in the debug screen.

    I even tried to Resend the email from the History of Uses, Orders page. That page shows the three attempts at purchasing a GC that I've tried, with the Resend button. Click on that .. nothing happens. FWIW .. all order emails are sent from Hikashop properly.

    Thank you for your assistance.

  • Your avatar
    seyi    
     11 months ago
    0

    Hello,

    If a gift certificate created shows on the screen awocoupon->history of uses->orders, then it should have been sent. Basically AwoCoupon forwards the email to the Joomla email system and gets a return message. If the message says it is sent, then it is added to that screen, if not, then the gift certificate created is deleted and nothing is added to that screen. And you would not see any debug information on a gift certificate that is already sent. So I wonder if it is a problem with your email receiving the gift certificate? Have you check the spam folder? Have you tried a totally different email system to test? You can try a throw away email at http://www.mailinator.com
  • Default avatar
    neil81    
     11 months ago
    0

    This is weird ... the email address I was using to test was getting the Hikashop order confirmation emails, but not the gift certificates. Now, its not even getting the order confirmations/cancellations; and the site is not blacklisted anywhere.

    I did switch to another email address I have setup and it works fine.

    Thanks and sorry for the false alarm.

    Neil