Multiple Coupons function not working


  • Default avatar
    leinad96    
     2 years ago
    0

    Hi Seyi,

    I have installed the AWOcoupon pro and tried to entered multiple coupons at one time but its doesnt seems to work.

    Installation : http://postimg.org/image/s8542mzzr/

    Config: http://postimg.org/image/jxgmxms2l/

    Let me know if you need to test out the site.
  • Your avatar
    seyi    
     2 years ago
    0

    Hello,

    If you try each coupon code separately do they work?

    If not, can you go to awocoupon->configuration, error message tab and change all the errors to something identifiable then try it again?
  • Default avatar
    leinad96    
     2 years ago
    0

    Hi Seyi,

    No error occurred but this is what it has happened.

    I keyed in 10off which will show -$10.00

    Then I entered 20off, it will not add on to -$10.00 , it just become $-20.00

  • Your avatar
    seyi    
     2 years ago
    0

    What version of AwoCoupon Pro are you using? The older versions do have the function of entering one at a time, you would have to enter them comma separated.
  • Default avatar
    leinad96    
     2 years ago
    0

    Hi Seyi,

    I am using 1.5.4 .

    Tried to enter using comma, also no use. example: 10ff, 20off
  • Your avatar
    seyi    
     2 years ago
    0

    Hello,

    Not able to produce. In awocoupon->configuration, can you remove the limit on multiple coupons and just verify that it is set to yes? Then try it again?
  • Default avatar
    leinad96    
     2 years ago
    0

    Hi Seyi,

    I have removed the limit of max 3 coupons. And it's set to Yes.

    Still not working.

  • Default avatar
    leinad96    
     2 years ago
    0

    Hi Seyi,

    It's still not working any advice on this?
  • Your avatar
    seyi    
     2 years ago
    0

    No, no idea. At this point, I would have to debug it to find why it is failing. But would need temporary admin/ftp access for that. If you can send a private message with that info, I can look at it.
  • Your avatar
    seyi    
     2 years ago
    0

    Ok, thanks for the access, found the problem as to why multiple coupons were not working. Onepage initializes the coupon session before process, but in the process, also empties the coupons in the cart "memory". So this was the fix I added to fix:
    in www/components/com_onepage/ajax/ajaxhelper.php, around 1927 was this:
    <?php
           $ps_coupon_process
    ->init_coupon_session();
    ?>


    I changed it to this:
    <?php
           $tmp 
    $_SESSION['coupon_awo_entered_coupons'];
           
    $ps_coupon_process->init_coupon_session();
           
    $_SESSION['coupon_awo_entered_coupons'] = $tmp;
    ?>


    And that seems to have fixed the problem.
  • Default avatar
    leinad96    
     2 years ago
    0

    Hi Seyi,

    Appreciated for your efforts. The onepagecheckout was disabled earlier on. It's working with the default checkout page.

    However, one issue with onepagecheckout is that when we key in the coupon for first time, the field to key in the coupon disappear after that. I am wondering if you could assist on this?

    Thanks & Best Regards.
  • Your avatar
    seyi    
     2 years ago
    0

    Great. The one page checkout with virtuemart 1, even when disabled still runs some of its code but in a normal checkout format.

    I really do not know the answer to the second question, it is probably be a very quick answer from the developer of the one page checkout. In fact there might be some option within opc to leave it open, you should check that.
  • Default avatar
    leinad96    
     2 years ago
    0

    I see. Thanks for your help and contacting with Stan too.