[Resolved] Manual coupon entry not showing discount when there is also a automatic shipping discount coupon published


  • Default avatar
    shopoftoys    
     a year ago
    0

    Joomla Version : 2.5.22
    Virtuemart Version : 2.6.10
    AwoCoupon Pro Version : 2.3.4. pro
    Template : VP_SuperMart v1.6 with
    Plug-in's : VP One Page Checkout v2.3

    Have two coupon codes set-up for example :
    1) Automatic Shipping Discount Coupon ABC applying to all products in Category A (for example)
    2) Manual Coupon code XYZ (for example) offering 7.5% discount off all products

    Scenarios :
    a) (OK) Purchase a product from Category A, automatic shipping discount applies and shows correctly the shipping discount in the cart view.
    b) (OK) Purchase a product from Category A and also enter coupon code XYZ, both the shipping discount and XYZ coupon discount applies and shows total discount correctly in the cart view.
    c) (NOT WORKING) Purchase a product that is NOT from Category A and enter coupon code XYZ, messsage "Discount Coupon successfully added" shows which is good, but NO discount is showing in the cart view and cart total is still the old total without the discount applied.

    But if I unpublish the Automatic Shipping Discount coupon and do scenario c) again, the discount from the XYZ coupon shows correctly in the cart view.

    Was sure it was working okay few months ago, not sure when the problem started, only detected it today. Any chance a bug might of crept in the latest v2.3.4 of AwoCoupon Pro ? As would of upgraded to the latest release not long ago, can't think of any changes we've done.

    Have tried with "enable multiple coupons" setting both on and off, but scenario C still broken in both cases.

    Any ideas ?

    Happy to send screen-shots in private message if need more info.
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    Please try this.

    In www/administrator/components/com_awocoupon/helpers/estore/virtuemart/couponhandler.php around line 707 is this:
    <?php
            
    if (version_compare($this->vmversion'2.9.8''>=')) {
    ?>


    Please change it to this:
    <?php
            
    if (version_compare($this->vmversion'2.6.0''>=')) {
    ?>


    Please test it in full to make sure all cases are still working
  • Default avatar
    shopoftoys    
     a year ago
    0

    Thanks Seyi, it seems to be working okay now with that change.

    Assume the change will also be included in the next version release ? To avoid manually applying it after each upgrade.

    Thanks
  • Your avatar
    seyi    
     a year ago
    0

    Yes correct, it will not be a problem on upgrade, that section of code will be fixed.
  • Default avatar
    shopoftoys    
     a year ago
    0

    Thanks again Seyi, very much appreciate your quick response and fix for the bug I found...