Items with AWO Coupons Dropping from Cart


  • Your avatar
    seyi    
     5 years ago
    0

    Anytime a product that has an AWO coupon is added to the cart, and another product with an AWO product coupon is added to the cart, one or both of them drop from the cart. Sometimes, even only one product added with an AWO product disappears from the cart. Please help me fix this problem.
  • Your avatar
    seyi    
     5 years ago
    0

    are you saying when you add a product to the cart, it removes itself? Ive never seen an error like that...
  • Default avatar
    bijou    
     5 years ago
    0

    Yes. Sometimes it works flawlessly where the items stay in the cart, and the coupon code amount comes off just fine. Other times, just adding another product with a coupon code attached to it, causes the previously added product with a coupon code to drop from the cart. Other times, both items show up, and when we input a coupon code, it'll drop an item and only take off the discount for the remaining product in the cart. It's very frustrating. Your extension is exactly what we are looking for, but it's not working at all. We even just bought the pro version thinking it would solve the problem.

    Let me be clear that our cart is only dropping items that have an AWO coupon code. Products that do not have a coupon code associated, work just fine. the url is bijouworld.com. It's NSFW content just to let you know.

    Also the license was purchased under a different username: steven7
  • Default avatar
    btealtn    
     4 years ago
    0

    Hi. I'm having a similar problem. Was there any resolution to this post?

    When I add products to the cart, they show up in the cart module (using mod_virtuemart_cart). But when I look at the actual cart using the Show Cart button, some of the products are not showing. I go back out to the Shop and they show up again in the module, but they do not show on the cart page.

    For instance, if I add product A and B to the cart and choose Show Cart, they are there. If I go back out and add product C to the cart, it does not show up on the cart page (but does show in the module). It is not necessarily only the products with a coupon associated with them, it's more like the order they are added.

    I uninstall AWO Coupons and everything works as expected. I purchased Purchasing Rules to work with your coupon component and really need it to work properly. Please assist.

    I made a copy of my site for development -gsjourney.heymisterdesigns.com - let me know if you'd like to login.

    Thank you.
  • Your avatar
    seyi    
     4 years ago
    0

    on the problem in the topic I believe after some more testing, it was found the problem was happening with or without AwoCoupon installed. And the problem was caused by some ajax search extension installed for Virtuemart.

    Your problem seems to be a little different as you say it only happens with AwoCoupon installed. If you can pm me temp ftp/admin access I can take a look at it.