Invalid argument supplied vm_coupon.php


  • Default avatar
    anthea5    
     3 years ago
    0

    Hi

    I have just purchased the AWO Coupon Pro edition (I am running Joomla 1.5.26 and Virtuemart 2.0.18). However, I am getting this error message when the customer enters a coupon on the checkout screen.

    Warning: Invalid argument supplied for foreach() in .../administrator/components/com_awocoupon/helpers/vm_coupon.php on line 157

    Also, I am having issues with the Buy X and Get Y coupon and wonder if this could be linked (basically the coupon is accepted and the Buy X Get Y rules are not being checked).

    I have tried uninstalling and reinstalling the Pro component but this has made no difference.

    Many thanks
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    Are you using AwoCoupon 2? If so the file you listed does not exist in that version:
    .../administrator/components/com_awocoupon/helpers/vm_coupon.php

    Please look in awocoupon->about to see what version you are using.
  • Default avatar
    anthea5    
     3 years ago
    0

    Hi

    I'm using Version: 2.1.7 pro.

    Thanks
  • Your avatar
    seyi    
     3 years ago
    0

    And you are receiving errors in vm_coupon.php? That really does not make sense. Your processor must be using the free version although you have the pro version installed. Please pm me temporary admin access to have a look and instructions on exactly how to produce the problem.
  • Default avatar
    anthea5    
     3 years ago
    0

    Hi Seyi

    Thanks for getting back to me.

    From your comment I have managed to understand what was going on. I had installed the free version of the component before installing the pro version and did not uninstall it first - this seems to be the problem. I have completely uninstalled AWO Coupon component and the VMCoupon and VMPayment plugins used by the component. I have now re-installed just the AWO Coupon Pro version and run the fix to get the plugins installed in Joomla 1.5.26. This has now fixed the issues which I have been having.

    Many thanks