I'm also having a "minim


  • Your avatar
    seyi    
     a year ago
    0

    I'm also having a "minim value not reached" issue after update to 2.3.5 on VM 2.6.16, and Joomla 2.5.28.
    The code does not work at all, the "minimum value not reached" error comes up no matter how much over the minimum the order actually is. Fix listed here does not seem to work.
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    When are you seeing this error? In the cart or after the order is processed?
  • Default avatar
    zoray2    
     a year ago
    0

    In the cart.
  • Your avatar
    seyi    
     a year ago
    0

    hello,

    Then the solution you referred to would not work, you are dealing with something else, not really sure though.

    In awocoupon->configurations->error messages, do you have 'minimum value not reached' message set? If not then this error is coming from Virtuemart, not AwoCoupon. Can you verify that the plugin VMCoupon - AwoCoupon is enabled?
  • Default avatar
    zoray2    
     a year ago
    0

    Yes, I do have a "minimum value not reached" message set in AwoCoupon, and that is the message I receive when I test the coupon. I have used coupons like this before without any problem and not exactly sure when it stopped working.
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    What are the details of the coupon that is not working?

    Other coupons in AwoCoupon are working?
  • Default avatar
    zoray2    
     a year ago
    0

    Yes, the coupon works fine as long as there is no minimum value set. Also, recently have done a Buy 2 Get 1 Free with parent coupon for specific items. Also seems to have worked fine.
    You can take a look at the error at http://sweetskins.com, using code "Testing20"
    It's meant to be $20 off for orders over $100.
    Z
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    I see you have a one page extension installed. Can you try this solution, I think there is a caching problem:
    http://awodev.com/forum/awocoupon/help-section/after-update-0-value-coupons-not-recognised#comment-8007
  • Default avatar
    zoray2    
     a year ago
    0

    You're the best!
    I guess the location and syntax are a little different now though, I found the line:

    static $_cart_items = array();

    at approximately line 1659,
    I added this line directly after it:

    $_cart_items = array();

    Seems to work!
    Thanks,
    Z