Creating new coupon - Product or Category-Assignment not saved


  • Default avatar
    martin5    
     3 years ago
    0

    Hi,

    I have the problem that the Product or Category-Assignment will not be saved when I create or update a coupon.

    Is there any bugfix available??

    Thanks for your help.

    best regards
    christoph
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    Is this for AwoCoupon 1.5.2? Are you able to select the specific products/categories on the add/edit screen? Did you make sure they were moved to the second box, by double clicking or adding it? Just highlighting the items will not save it.
  • Default avatar
    martin5    
     3 years ago
    0

    Hi,

    yes I have installed V1.5.2 and I have double-clicked the items.
    If I choose customers or customer groups the items will be saved but products or categories are ignored.

    Thanks.
  • Default avatar
    martin5    
     3 years ago
    0

    Hi,

    the product or categories are saved in the database, but in the admin-interface the list will not be extended and the chosen products are not listed.

    Maybe there is anything wrong?

    Hopefully you can help me.
  • Default avatar
    martin5    
     3 years ago
    0

    Hi,

    I have found the problem.

    The SQL-Statement in the getAwoItem-Function in awolibrary.php was wrong for me.

    All I did was to change the order of the last two select-statements in the query.

    Original:
    ** Removed code **

    My Change:
    ** Removed code **

    But thanks a lot for the rapid help.

    Best regards!!!!
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    I have looked at your changes and I really do not think changing the order should affect anything.

    I think you may have another error in the database. Have you tried going to global configuration and turning debug mode on then trying to save? I think you would receive an error (at least with the original code) similar to the one in this forum post:
    http://awodev.com/forum/awocoupon/help-section/error-showing-coupon-created-buy-one-get-one-half-price#comment-3883

  • Default avatar
    martin5    
     3 years ago
    0

    You were right :-)

    Wrong Collations and so the order-change don't effect anything.

    Thx a lot.
  • Your avatar
    seyi    
     3 years ago
    0

    You are welcome. Glad its fixed.