Coupons not responding in cart.


  • Default avatar
    melissa    
     4 years ago
    0

    I can't get awocoupons to work on my site.

    I'm using virtuemart 2.0.8c and I just updated awocoupon to 2.0.9

    When creating a coupon I can't choose specific products from my shop to apply discounts to. And then when I'm attempting to check out with any awocoupon code of any kind, it's just like the cart doesn't recognize it at all. It doesn't give me any error messages or anything. It just doesn't work.

    Is awocoupon not communicating with my virtuemart shop? Is it not recognizing my shoppers and products for some reason?

    Please help.

    Thank you.
  • Your avatar
    seyi    
     4 years ago
    0

    hello,

    when creating a coupon, to have all the products show, click on the 'view all button', which should then display all your products.

    As for the front end not working, take a look at awocoupon dashboard, is the awocoupon plugin for virtuemart published?
  • Default avatar
    melissa    
     4 years ago
    0

    Hi Seyi,

    There is no "view all" button. It's like it's not recognizing any of my products at all. The plugin is published too.

    I used to use Awocoupon all the time when my site was on joomla1.5/VM1, so I'm fairly familiar with creating coupons, which is why I'm so confused on why it's not working ok now that I have everything upgraded.

    Do you have any other suggestions that might be preventing it from working? I pretty much rely on a new coupon code every week for my store, so it's been kind of hard not having this working.

    Thanks.
  • Default avatar
    melissa    
     4 years ago
    0

    Ok, so if I log in using Firefox instead of Chrome I'm given the option of choosing which products I want the discount applied to. So the option IS there, but it's not showing up in Chrome for me. Why would that be?

    Also, now that I can apply the coupon to a product, when I try a test run of the code I'm given these errors:

    Warning: Invalid argument supplied for foreach() in /home/green292/public_html/shop/components/com_virtuemart/views/cart/tmpl/default_pricelist.php on line 36

    and

    Fatal error: Call to a member function createPriceDiv() on a non-object in /home/green292/public_html/shop/components/com_virtuemart/views/cart/tmpl/default_pricelist.php on line 146

    So, what do I do now?
  • Your avatar
    seyi    
     4 years ago
    0

    For the chrome problem, it is likely cache. You were using an older version of AwoCoupon which loaded the .js file into your caching system. Now that you have upgraded, it is still calling the old .js file. In order to call the new one, you will need to clear the cache of google chrome.

    I am not familiar with the virtuemart error you posted. Is this caused only when you run a coupon code? What version of virtuemart are you using?
  • Default avatar
    g j f2    
     4 years ago
    0

    I had the same problem in chrome, in IE it worked fine.

    When I turned off System - Mootools Upgrade in plugins it worked fine in chrome and I can make a coupon
    Mayby this helps to find a solution.

    It is not verry handy to switch of and on System - Mootools Upgrade everytime if you want to make a coupon

    Thanks
  • Your avatar
    seyi    
     4 years ago
    0

    No, that would be bothersome. I have system mootools upgrade enabled and can add a coupon fine in google chrome. There must be some other reason. have you right clicked on google chrome, selected 'inspect element', and checked the 'console' tab to see what the javascript error is that you are having?
  • Default avatar
    g j f2    
     4 years ago
    0

    Can't find there a script error...

    It happend after a upgrade, so I cleaned the cache in chrome again to be sure, (and in joomla etc, cleaned history also.... dide this al in one so I cant say wich one it was ...)

    It seems to work ok for now with mootools on.

    Thanks again for the quick response
  • Default avatar
    melissa    
     4 years ago
    0

    I'm using VM 2.0.8e and I seem to be having lots of issues with this new VM.....