Coupon not applying at payment processing


  • Default avatar
    paul596    
     3 years ago
    0

    I have installed the AwoCoupon component and enabled both plugins. I created several test coupons and added them to my cart during a sale. My cart updated correctly; however, the coupon does not get applied during payment processing. In essence, the cart displays the discounted price correctly, but the customer is charged full price as if the coupon had never been applied.

    I have tried several coupon types (coupon for a percent off, shipping discount, etc.). All have the same result. The cart recognizes and displays the correct total on screen to the customer, but fails to apply during payment processing.

    Using:
    J2.5.16
    Awo v. 2.1.9
    VM v. 2.0.24
    Paypalpaymentspro3dssc
    PHP v. 5.3.3
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    Please see this discussion on paypal pro for virtuemart 2:
    http://awodev.com/forum/awocoupon/help-section/coupons-and-gift-certificates-not-working-paypal-pro

    There is a major problem with it for discounting.
  • Default avatar
    paul596    
     3 years ago
    0

    Is there a solution to this issue? In looking at the link you provided, it appears there isn't a solution if I want to use Paypalpaymentspro3dssc. Is that correct? If that is the case, that would have been good to know prior to purchasing this component.
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    There is no problem with AwoCoupon.

    If you read my post and follow the instructions, you will see you have the same problem with core Virtuemart coupons.

    I do not have a solution for that component, and you would need to contact the developer of the component. It really is not possible for AwoCoupon to account for code that does not even work properly with the core.