"coupon code not found" when discount is set to percentage. (When changed to amount, code is found and working)


  • Default avatar
    paul82    
     a year ago
    0

    Hi,

    We have created emails that will be sent to new clients. In this email we added a discount code which people can use when the order in our webshop. When we set the template to "percentage" a code is generated in the email BUT when we try to enter the code during check out we get the following error message: Coupon code not found. Please try again.

    But, when I change the template and create a coupon with a discount "amount", the code works during checkout...

    Could you please help me and tell me what I am doing wrong (what I should change in the template setting to have the discount percentage work?)

    Cheers

    Paul
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    Not entirely sure what is going on. What version of AwoCoupon is this? Can you give the full details of how you created the coupon template? If you are using the pro version, you can go to awocoupon->configuration->error messages and click the debug button and save. Then when using hte coupon in the front end you should see why it is failing.
  • Default avatar
    paul82    
     a year ago
    0

    Hi Seyi,

    We use this version: Version: 1.5.1 pro

    I have setup the template like this:

    function type: Coupon
    Function type 2: Product
    Couponcode: Welkom1.0
    Published: Template
    Percentage or amount: Percentage
    Discount type: General
    Value: 5,38%

    Optional:
    Times used: per customer, 1#

    And for Acymailing we use the AWO mailing (tag) plugin

    So, when an email is sent out, this TAG is in the email body: {awocoupon:[name][key]|150|[na]|1|[na]|[na]}

    This is an example of a created code from our backend : Davy_BerghlMb5LH :Coupon (Product);Percentage 5.38; Unlimited General; 1 clients; all products; published

    What happens is that the codes that are created with a percentage-discount don't work... And when I change the template to give a discount-amount it does work.

    I hope this information will help you understand the problem I have.

    Cheers, Paul
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    So are you changing the template to give an amount discount or the coupon which was generated from the template that does not work?

    For the coupons that do not work, have you tried going to awocoupon->configuration->error messages and changing all the errors to something identifiable and trying the coupon in the front end to see why it is failing?