Coupon code not applying discount


  • Default avatar
    mbrando    
     2 years ago
    0

    Hello,

    We have a site that is using

    Installed AWO Version: 2.3.2
    Joomla! 2.5.27
    VirtueMart 2.6.10

    The scenario goes like this. A user is given a one time use parent coupon that has to children. One $75 dollars off and one 100% off shipping.

    The user loads up their cart and checks out. At check out they enter the coupon code and no discount is applied to the cart. Their is not criteria for discount like buy more than $50, it is just $75 dollar value.

    However, the coupon get marked in the AWO history as used with no virtuemart order or date assigned. Since it was a one time use coupon, they cannot try again as AWO has marked it as used.

    How do I start looking at fixing this or figuring out what is going on?

    -Mike
  • Your avatar
    seyi    
     2 years ago
    0

    Hi Mike,

    Ok, so there are 2 things I would do:

    - verify that the parent coupon has the process type set to 'all that apply'. If it is set to 'first found match', then it would process the first coupon. And if your first coupon is shipping but you have not selected it yet, then this would explain the diacount being accepted with no real discount

    - if that is not the problem, then first create the problem in the front end, then remove the coupon and try each coupon individually. You can also go to awocoupon->configuration->error message, and click debug to see why a coupon is failing
  • Default avatar
    mbrando    
     2 years ago
    0

    Hello,

    Part of the problem is that I cannot manually reproduce. When I do my testing it works correctly. Yet some customers still run into this issue. I'll check the error messages and see what is in there.

    - Mike
  • Default avatar
    mbrando    
     2 years ago
    0

    What should this be set to?

    Order state to trigger coupon processing

    Order creation or confirmed?

    - Mike
  • Your avatar
    seyi    
     2 years ago
    0

    This is really op to your shop. If coupons are being removed before the order completes then I would set it to confirmed.

    I explain more of what is happening here:
    http://forum.virtuemart.net/index.php?topic=120972
  • Default avatar
    mbrando    
     2 years ago
    0

    Hello,

    I think the remove on confirm will fix this.

    Thank you.

    - Mike