Coupon Amount Incorrect in Email


  • Default avatar
    MyWorld    
     4 years ago
    0

    I'm not sure if this issue is with HikaShop or awoCoupon.

    On the site it shows the discount is showing correctly, for example,

    Total $59.40
    Coupon -$5.00
    Shipping $5.00


    But when I receive the email order it shows it like this. Why is the coupon -$1.16 instead of $5:

    Coupon : $-1.16
    Shipping Method : $5.00
    Taxes : $4.49
    TOTAL with Tax : $33.54

    Thanks!!
  • Your avatar
    seyi    
     4 years ago
    0

    I tested using an amount coupon, a percent coupon, using discount before tax and after and in all cases the coupon discount matched the discount sent in the email. So it may be something within the email template.
  • Default avatar
    MyWorld    
     4 years ago
    0

    Hi Seyi,

    I tested it again and the totals are correct but the shipping amount in the email is incorrect. Hikashop told me to test their coupon to see if the error is from their end but I'm unable to do so because awoCoupon is not allowing me to disable the coupon because I made a copy of the site to work on and it's saying... "Website does not match local key".

    So, it's hard for me to tell where the issue is coming from and I need this resolve soon as the client is waiting.

    The coupon is supposed to be - $5.00. It's showing $7.35.

    Total: $100
    Coupon : $7.35
    Shipping Method : $5.00
    Taxes : $13.00
    TOTAL with Tax : $113.00

    Thanks!!
  • Your avatar
    seyi    
     4 years ago
    0

    You can either disable awocoupon or enable hikashop coupons to work along with awocoupon quite easily.

    To disable, on awocoupon dashboard, click the unpublish icon in the status section.
    To enable hikashop coupons to work, in awocouon->configuration, set 'enable store coupons' to yes
  • Default avatar
    MyWorld    
     4 years ago
    0

    Oh ok. Didn't see that. Thanks!!
  • Default avatar
    MyWorld    
     4 years ago
    0

    I still haven't gotten this sorted out yet and I CANNOT make changes to the coupon in order to test it. Can we not get access to "test sites" in order to test? This is a test site that I created under the main website.

    I really need to get this done for the client but I don't want to test it on the live site.

    Thanks!!
  • Default avatar
    MyWorld    
     4 years ago
    0

    Can I please get some help ASAP please? Thanks!
  • Your avatar
    seyi    
     4 years ago
    0

    Hello,

    What specifically do you need help with? You need to test on a test website? we do not currently have a demo site for hikashop but you can test it on your test website. Your license is not permanent, so can be altered to work on different site. Please read through the licensing here:
    http://awodev.com/documentation/frequently-asked-questions#licensing
  • Default avatar
    MyWorld    
     4 years ago
    0

    Thank you that's what I needed. Sorry, I did not check the documentation.

    I have been testing the coupon code and the HikaShop Coupon is working fine but awoCoupon is not.

    This is an example that I used with awoCoupon and the total is incorrect. The total should be $113.

    Total: $100.00
    Coupon : $-5.00
    Shipping Method : $5.00
    Taxes : $13.00
    TOTAL with Tax : $108.00


    This is an example that I used with HikaShop and the total is correct.

    Total: $100.00
    Coupon : $-5.00
    Shipping Method : $5.00
    Taxes : $13.00
    TOTAL with Tax : $113.00


    Thanks!!
  • Your avatar
    seyi    
     4 years ago
    0

    what are the details of how you setup the coupon code in awocoupon?
  • Default avatar
    MyWorld    
     4 years ago
    0

    This is the setup:

    Function Type: Coupon
    Function Type 2: Shipping
    Coupon Code: test
    Published: Published
    Percent or Amount: Percent
    Discount Type: Overall
    Value: 100.00

    Number of Uses: per Customer
    Minimum Value: Overall 20.00

    Shipping: All categories are selected

    Thanks!!
  • Your avatar
    seyi    
     4 years ago
    0

    Well yes, you could not produce this in hikashop coupons mainly because there are no shipping coupons. Have you tried it with regular coupons in awocoupon, do you get the same result? Just to clarify the error is you get a different total in the order email correct? I test this email configuration and my totals worked out fine.

    Have you looked at your email template?
  • Default avatar
    MyWorld    
     4 years ago
    0

    I know that I could not produce the exact test in hikashop, what I was looking to see is if hikashop email result would have been incorrect when I tested their coupon - it was not. I assumed that if it were incorrect then the issue would have been on their end. Also, I'm not sure why the email template would work for hikashop and awoCoupon.

    I tested another coupon with the following options:

    Function Type: Coupon
    Function Type 2: Product
    Coupon Code: product1
    Published: Published
    Percent or Amount: Amount
    Discount Type: Specific
    Value: 10.00

    Number of Uses: Total
    Minimum Value: Overall 20.00

    Shipping: All products are selected


    This is the result both on the website and in the email.

    Total $100.00
    Coupon $-10.00
    Shipping $5.00
    Taxes $10.40
    Order Total $95.40 (The total should be $105.40)


    If I give you access to the site would you mind taking a look for me. I try to figure things out as much as possible but I've been at this for about 5 days without luck and the client is getting a bit restless.

    Thanks!!
  • Your avatar
    seyi    
     4 years ago
    0

    certainly, please send a private message.
  • Default avatar
    MyWorld    
     4 years ago
    0

    I just sent you a PM. Thanks in advance!!
  • Your avatar
    seyi    
     4 years ago
    0

    Ok, the problem is the coupon function is being called twice, causing the discount to happen twice. AwoCoupon has some custom code within Hikashop to make sure awocoupon is called. With the latest version of Hikashop, the code is there by default and so the custom code is not necessary. To fix, go to awocoupon->installation check and uninstall everything.
  • Default avatar
    MyWorld    
     4 years ago
    0

    I went to "awocoupon" > "Installation check" but I only see "Install" I don't see an option to uninstall.

    Thanks!!
  • Your avatar
    seyi    
     4 years ago
    0

    Under the status column, it probably said 'not installed' for each item? This is why you could not find the uninstall, I have already done it.
  • Default avatar
    MyWorld    
     4 years ago
    0

    That's odd, because it's still saying "Not Installed" :(

    Should I just uninstall the entire thing and start over. I really need to get this working....
  • Default avatar
    MyWorld    
     4 years ago
    0

    OK. So I clicked on "Installed", and they are showing as installed but under name it says "Core (Required)".

    I tested it again and the total is still not correct. The total should be $113. The tax amount is incorrect - it should be $13.

    Total $100.00
    Coupon $-5.00
    Shipping $5.00
    Taxes $11.70
    Order Total $106.70
  • Default avatar
    MyWorld    
     4 years ago
    0

    I started from scratch and reinstalled everything and reentered the coupon code.

    The settings are as follows:

    Function Type: Coupon
    Function Type 2: Product
    Coupon Code: test
    Published: Published
    Percent or Amount: Amount
    Discount Type: Specific
    Value: 5.00


    The calculation for the coupon is incorrect but the total is correct.

    Total $100.00
    Coupon $-4.42
    Shipping $5.00
    Taxes $13.00
    Order Total $113.00

    I REALLY need to get this working soon as the client is getting very irritated now so can you please login and see what needs to be fixed.

    Thank you!!
  • Your avatar
    seyi    
     4 years ago
    0

    In awocoupon->configuration set Calculate the discount before tax (Coupons) to yes
  • Default avatar
    MyWorld    
     4 years ago
    0

    I changed it as suggested but now it changed the taxes. Taxes should be 13% so the total should be $113.

    Total $100.00
    Coupon $-5.00
    Shipping $5.00
    Taxes $12.35
    Order Total $112.35
  • Default avatar
    MyWorld    
     4 years ago
    0

    I see the below in the backend under "Coupon > Products". Could that be what is causing the issue?

    Warning: Invalid argument supplied for foreach() in /home/.../public_html/.../administrator/components/com_awocoupon/views/coupon/tmpl/default.php on line 303
  • Default avatar
    MyWorld    
     4 years ago
    0

    Finally! The email and the website are now showing the correct/same amount. I don't even know exactly what is is that made it worked as I changed so many things :( Anyway it works now!

    When the page is redirecting to paypal I see this message at the top of the page. Is this a hikashop question?

    Warning: Invalid argument supplied for foreach() in /home/.../public_html/.../components/com_hikashop/controllers/checkout.php on line 1204

    Thanks!!