Blank Page New Coupon


  • Default avatar
    phrigapov    
     a year ago
    0

    Hi,

    In the New coupon page, she is appearing in blank, appears only the top buttons, Coupon, Gift certificate, Shiping, buy xy, parent, but below this all white and I can not create the coupon
  • Default avatar
    phrigapov    
     a year ago
    0

    Joomla! 2.5.24

    Latest Version Installed
    Installed Version: 2.3.6
  • Default avatar
    phrigapov    
     a year ago
    0

    other screens also are blank, however when I press a button "html" or "text" fields appears
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    Yes, initially you are only going to see the buttong accross the top. If you click one, example 'coupon' then the relevante fields will appear allowing you to create the coupon.
  • Default avatar
    phrigapov    
     a year ago
    0

    No Seyi, the fields do not appear when I press, that's the problem
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    Then I believe you have some type of javascript error. More than likely jquery is being loaded twice. Can you inspect element in firefox or chrome to see what error is happening? Or look at the source to see if jquery is being loaded multiple times?
  • Default avatar
    phrigapov    
     a year ago
    0

    google chrome inspect:


    Consider using 'dppx' units, as in CSS 'dpcm' means dots-per-CSS-centimeter, not dots-per-physical-centimeter, so does not correspond to the actual 'dpcm' of a screen. In media query expression: (min-resolution: 0.001dpcm)
    index.php?option=com_awocoupon&view=coupon:1Consider using 'dppx' units, as in CSS 'dpi' means dots-per-CSS-inch, not dots-per-physical-inch, so does not correspond to the actual 'dpi' of a screen. In media query expression: only screen and (-webkit-min-device-pixel-ratio: 1.5), only screen and (min-resolution: 144dpi)
    index.php:256 Uncaught TypeError: jQuery(...).dropdown is not a function
    2awocoupon.js:52 Uncaught TypeError: Cannot read property 'autocomplete' of undefined
  • Your avatar
    seyi    
     a year ago
    0

    Hello,

    Seems to be a jquery problem. Can you view the source code to see if it is loaded more than once? If so, the extension you have installed that loads it on all pages, can you add an exclude for AwoCoupon?

    If you prefer I look at it directly you can send a private message with temp admin access.
  • Default avatar
    phrigapov    
     a year ago
    0

    Ok I will send private message.
  • Your avatar
    seyi    
     a year ago
    0

    Ok, took a look and see that these are being loaded:





    Looking at the plugin System - YT Framework, there is an option to exclude components, so I added awocoupon. But it does not work, I guess it is only for excluding on the front end?

    Because of where it is added, disabling AwoCoupon Jquery will still cause errors, so the only thing to do is remove the yt jquery. For that it would require editing the yt plugin. I can do it but would need a copy of the plugin file, or temp ftp access.

    And just as a test, I did temporarily disable the yt plugin. After doing that, AwoCoupon worked fine.
  • Default avatar
    phrigapov    
     a year ago
    0

    Ok, I will send PM MESSAGE