blank page on administrator awo coupon


  • Default avatar
    denis26    
     3 years ago
    0

    Hi seyi,

    Version: awocoupon 1.5.2 pro in joomla 1.5.26 / this error BLANK PAGE on 2 websites.

    the blank page it's only in this url : administrator/index.php?option=com_awocoupon

    this page run ok "no problem" : administrator/index.php?option=com_awocoupon&view=coupons

    in my error.log :
    [Fri Nov 29 12:44:02 2013] [warn] [client xx.xx.xx.xx] mod_fcgid: stderr: PHP Fatal error:  Call to a member function data() on a non-object in /home/mysite/public_html/administrator/components/com_awocoupon/models/awocoupon.php on line 175


    the line 175 its on my notepad++ :
    $check['version']         = & $version->data();


    websites with this error :
    www.tahitiperlesetmineraux.com
    and
    www.ligne-droite-roller.com

    thank-you :)
  • Default avatar
    denis26    
     3 years ago
    0

    Hi Seyi

    if i comment line 84 to 185 on my file : " administrator/components/com_awocoupon/models/awocoupon.php "
    cut chapter : function getVersionUpdate

    the web page another run (administrator/index.php?option=com_awocoupon)
    and screen this message at top :

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, class 'AwoCouponModelAwoCoupon' does not have a method 'getVersionUpdate' in /home/mywebsite/public_html/libraries/joomla/cache/handler/callback.php on line 99 


    ?? trouble problem...

    tank-you, Denis
  • Default avatar
    denis26    
     3 years ago
    0

    hello (strange, my last post is not at the bottom of the list of posts ...)

    I again reviewed the file (with / * and * /)
    Line 84 to 225
    in :
    administrator/components/com_awocoupon/models/awocoupon.php

    so I have no more error messages in the page

    for french users

    Pour éviter la page blanche avec l'url : administrator/index.php?option=com_awocoupon

    J'ai commenté le fichier : administrator/components/com_awocoupon/models/awocoupon.php
    (avec /* et */)
    de la ligne 84 à 225

    ainsi je n'ai plus aucun de messages d'erreur dans la page
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    If you are using PHP 5.x then revert awocoupon.php back to the original and then starting on line 170 you will see this:
    <?php
                $xml 
    = & JFactory::getXMLparser('Simple');
                
    $xml->loadString($data);
                
                
    $version                 = & $xml->document->version[0];
                
    $check['version']         = & $version->data();
                
    $released                 = & $xml->document->released[0];
                
    $check['released']         = & $released->data();
                
    $check['connect']         = 1;
                
    $check['enabled']         = 1;
                
                
    $check['current']         = version_compare$check['current_version'], $check['version'] );
    ?>


    Change it to this:
    <?php
                $element 
    simplexml_load_string($data);
                
                
    $check['version']         = (string)$element->version;
                
    $check['released']         = (string)$element->released;
                
    $check['connect']         = 1;
                
    $check['enabled']         = 1;

                
    $check['current']         = version_compare$check['current_version'], $check['version'] );
    ?>


    That should fix it.
  • Default avatar
    denis26    
     3 years ago
    0

    hi,
    thank you, it's a solution !

    you are a great man :)
  • Default avatar
    borodulya    
     2 years ago
    0

    work good, fnks