blanck page with awo coupon !!


  • Default avatar
    strouve    
     3 years ago
    0

    Hello,

    after all is ok and many test, i found a problem. when i put child product in my bag, the bag page is blank and my access to account is a blank page too. this with automatic coupon

    I have only 1 simple coupon at 10 %

    and when i put on manual coupon, i have an internal server error 500.

    i disable the 2 plugin and all is correct with basic virtuemart coupon.

    what can i do ?

  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    Can you pm me temporary admin access let me know which coupon is causing the problem? I am not able to replicate this problem locally.
  • Default avatar
    strouve    
     3 years ago
    0

    i just send you a private message with admin website.
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    Took a look. I turned on error reporting to maximum, and this is the actual error:
    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 78 bytes) in /var/www/vhosts/ns354723.ovh.net/site4/libraries/joomla/database/database/mysql.php on line 697


    I took a look at your php settings and your memory limit is set to 128 megs. This is probably a little low. If you can get that increased to at least 256 megs, the error will go away.
  • Default avatar
    strouve    
     3 years ago
    0

    Hello,

    I realise this, i put the memory in php.ini at 256 but i have the same problem. Do you think it's because we have to many products in virtuemart shop.
  • Your avatar
    seyi    
     3 years ago
    0

    Ok, very strange.

    Can you please send me temporary admin and ftp access via private message to try and debug the problem?
  • Default avatar
    strouve    
     3 years ago
    0

    i just post a private message with the acces to admin and ftp admin.
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    I did some debugging and found that for whatever reason, the below code insde www/administrator/components/com_awocoupon/helpers/estore/virtuemart/couponhandler.php keeps giving the fatal error or running out of memory.
    <?php
            $product 
    $model->getProduct($virtuemart_product_idtruefalse);
    ?>


    So I commented it out and add new code to grab the product like this
    <?php
            
    //$product = $model->getProduct($virtuemart_product_id, true, false);
            
    $product $model->getProductSingle($virtuemart_product_id); # seyi_code
    ?>


    And that seems to work. I do not know why the Virtuemart getProduct is failing, I think it might have to do with cache, but getProductSingle is working fine.
  • Default avatar
    strouve    
     3 years ago
    0

    all is fine now. many thanks for the support.