AwoReferral Back-End/Front-End Issue. Permanent License Is Not Being Excepted


  • Default avatar
    romatawo    
     3 years ago
    0

    Dear Awo,

    I am having an issue with AwoReferral. The back-end layout seems to be messed up for some reason and in the front-end, it won’t let users to send referrals displaying an error message. I tried to go to config and noticed that license has expired. So I made it permanent and tried to upload it, but it’s not taking it. Could you please take a look ASAP?

    Thank you in advance.
  • Default avatar
    romatawo    
     3 years ago
    0

    Another problem is that I made the license permanent and now I can't test it on my QA environment.

    Please help.
  • Default avatar
    romatawo    
     3 years ago
    0

    I think I figure it out. Configuration was missing in the back-end. So I think I found a bug in your extension that is costing me a lot of time to fix.

    I think what happened is when the license expired, it wiped out the back-end config. Now I have to fix the whole thing...:(
  • Default avatar
    romatawo    
     3 years ago
    0

    my backup file perfectly extracts, but I can't use the software, because license is expired on my QA even though it's permanent on the live site.

    What would you recommend on doing?

    Thanks.
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    I am not sure what caused your configuration to be wiped out but it is not the license expired that caused this. Expired license does not affect any of the configuration, it only limits backend access. In fact, if your license expires, the front end functionality will keep working without restrictions. The only thing is you as an administrator will not be able to see what is going on in the backend.
  • Your avatar
    seyi    
     3 years ago
    0

    I have sent you a private message.
  • Default avatar
    romatawo    
     3 years ago
    0

    Hi Seyi. I have just replied. Again, I am sorry for the late response. Quick question, if I update your extension to the newer version, will I loose my settings? I shouldn't, correct?
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    No, upgrading does not affect your configurations, those should always be in place.
  • Default avatar
    romatawo    
     3 years ago
    0

    I see. That's strange. I wonder what caused it then. Thanks.