AwoCoupon Email Plugin - No email is being sent on order status change.


  • Default avatar
    sales8    
     4 years ago
    0

    Hi,

    I am trying to get my email plug in working for email on orders. The test mode works fine but when I disable it and change an order status to shipped no email is sent. Is there any way I can fix this? My selected final status is "Shipped" btw. Any help would be much appreciated
  • Your avatar
    seyi    
     4 years ago
    0

    Hello,

    Please read this post on how the plugin works:
    http://awodev.com/forum/awocoupon/help-section/order-email-dynamic-tags-expiry-date#comment-3327

    It may just be delayed
  • Default avatar
    sales8    
     4 years ago
    0

    oh ok, got it. Thank you for your reply. One more thing. If I keep changing and saving this setting will this add onto the time or subtract. For example I set the number of emails to 1 and then change my mind for 1000. would the plugin then add on the time of 24hrs + 1 1/2 mins?
  • Your avatar
    seyi    
     4 years ago
    0

    When you set the time, the new time is placed in a temporary file. When you change the time, the temporary file is not updated. So the new time will take effect when the old time has run out. If you want to reset it, you can delete the file. Here is where it is:
    www/media/awocouponEmail_checkfile.[timestamp]

    where [timestamp] is a bunch of numbers.
  • Default avatar
    sales8    
     4 years ago
    0

    ok, deleting the file did work. Thank you again. I do have one other question if its ok to post it here. When I want to send a test email to an order that was placed today or yesterday it doesn't find any orders, but if set to previous dates it finds them. All of the criteria of the order match my settings for the recent orders. Is there anything that I may be doing wrong here? Thanks again.
  • Default avatar
    sales8    
     4 years ago
    0

    ok, i figured out the problem there. After the setting the email plugin out of test mode it will automatically send emails from the date entered. After these emails are sent it seems that since these emails were already affiliated with the order number it is already in the coupon code list in the AwoCoupon component and a test email will not be sent out for that order. That seemed to be what it is. Maybe it will help someone else who couldn't figure that one out :-) Thanks!