Awo Pro 2 Virtuemart 2 not recognizing the coupon but does the discount


  • Default avatar
    bc2007    
     4 years ago
    0

    Hello,

    I am using VM 2.012 with Awo Coupons Pro 2 (bought it for the super discount options)

    I have added an automatic discount coupon and it does the discount well in the checkout for the product on the list.
    It really renders the discount well.
    But than get an message above that the Discount coupon is not found, Please try again.
    And at the line where you can put manually your coupon code, it says: change the coupon code.

    In this stage the checkout is not possible to go on...
    What is the problem here, do you think?

    thanks in advance..
  • Your avatar
    seyi    
     4 years ago
    0

    Hello,

    There was a problem with the messaging in an earlier version. Are you using the latest? If not please update your version.
  • Default avatar
    bc2007    
     4 years ago
    0

    Yes really use the latest version.
    Yesterday I downloaded from this account and installed it with overwrite.
    I did need to uninstall previous is it?

    So what is it at this point, do you think?

    Thanks!
  • Your avatar
    seyi    
     4 years ago
    0

    Hello,

    Can you send me a private message with access and instructions on exactly how to reproduce the problem?
  • Your avatar
    seyi    
     4 years ago
    0

    I think there might be some interaction problems with opc but I changed some code around and figured out how it could work with it any way. This will be updated in the never version of AwoCoupon. Your code is updated and you should not receive any more warnings.
  • Default avatar
    bc2007    
     4 years ago
    0

    yes thanks for the work about it...
    Maybe my onepagecheckout component does interact awocoupon?

    But now I am missing the product price in the column when its amount is 3 or more

    for example 1 product of detox+ = 23.90
    2 products of detox+ = 47,90
    but when 3 of them there is no price mentioned anymore ......
    only at the bottom after whole calculation

    Can you please look at it and I hope repair....

    Thank you so much!!
  • Your avatar
    seyi    
     4 years ago
    0

    took a look, seems in one page checkout the salesPrice is being called from the product array, where it is not set. But it is always set in the prices array. So in /public_html/components/com_onepage/helpers/loader.php, at line 1103, changed
    <?php
                  
    else
                 
    $product['product_price'] = $prow->salesPrice;
    ?>


    to this
    <?php
                  
    else
                  
    $product['product_price'] = $ref->cart->prices[$pkey]['salesPrice']; # seyi_code
                  //$product['product_price'] = $prow->salesPrice;
    ?>
  • Default avatar
    bc2007    
     4 years ago
    0

    The price is ok now thank you!!!

    but now the message is back but now
    at the step when you logged on with my administrator login (e.g.) and than choose e.g. ideal for paying.....

    than the message appears again at the top...and you cannot go on with the checkout...
  • Your avatar
    seyi    
     4 years ago
    0

    yes, there seems to be an interaction problem somewhere.

    Looking at Virtuemart coupons, it looks like you are not really using them. So I went to awocoupon->configuration and set 'enable store coupons' to 'no'. That fixed it.
  • Default avatar
    bc2007    
     4 years ago
    0

    If you enable it, than another coupon I use for clients will not work anymore?
    I need to use couponcodes manually added by clients too.....

    sorry can you really fix it please....
  • Your avatar
    seyi    
     4 years ago
    0

    found the problem, it is now fixed, within AwoCoupon. This error also causes this error:

    After inserting coupon or with automatic discount, the url goes to "index.php?option=com_virtuemart&view=cart&task=edit_coupon" and the page is a classic page without css style and two error string

    1- Warning: Invalid argument supplied for foreach() in /home/####....###/templates/..../html/com_virtuemart/cart/default_pricelist.php on line 36

    2-Fatal error: Call to a member function createPriceDiv() on a non-object in /home/###...##/templates/....../html/com_virtuemart/cart/default_pricelist.php on line 147


    The fix was within AwoCoupon, in
    www/administrator/components/com_awocoupon/helpers/estore/virtuemart/couponhandler.php, around line 81 is this:
    <?php
            
    if($instance->params->get('enable_store_coupon'0) == 1) {
    ?>


    changed it to this
    <?php
            
    if($_code!='('.JText::_('COM_AWOCOUPON_CP_DISCOUNT').')' && $instance->params->get('enable_store_coupon'0) == 1) {
    ?>


    And that fixed the problem.
  • Default avatar
    bc2007    
     4 years ago
    0

    Thank you so much for dissolving this error!
    You are really giving good services!
    Thanks again and if I need another product I will not hesitate !

    Greetz

    Ps is this coming in an update of Awocoupon? Because if not, than I get the problem again....
  • Your avatar
    seyi    
     4 years ago
    0

    Yes, these fixes will be added to the next available version.