AWO Coupon - Shipping Choice Does Not Apply - RedShop


  • Default avatar
    peaces    
     3 years ago
    0

    I have read a few posts about this or similar issue with VirtueMart. I use RedShop (RedComponent).

    I am using the single page checkout. If I use a coupon created from RedShop and the user selects the shipping method "Do Not Ship", the shipping charges are removed from the cart.

    If I use a coupon created by AWO and the user checks "Do Not Ship" as the shipping method, there is no change in the cart.

    Can you help me please. I have a huge promotion about to take place and must use AWO for my coupons.
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    I need some more information. What versions of Redshop and AwoCoupon are you using? By single checkout, do you mean in Redshop configuration you have "One step checkout" set to "yes" ore are you using some type of 3rd party checkout? So by default does your shopping cart select a specific shipping method? And when on the checkout, the customer can make a different choice affecting the price? And then by ajax, the order total and shipping cost should automatically change without refreshing the page? If so there is probably a javascript error causing the prices not to change, which means it could also be browser related. What browser are you using?
  • Default avatar
    peaces    
     3 years ago
    0

    AWO Pro 2.1.2
    RedShop 1.1.11
    Joomla 2.5.7

    One Step Checkout

    Shipping Methods set up in RedShop FedEx Home Ground and Do Not Ship (price is set to $0)
    Default set to Fed Ex Home Ground
    User can choose the "Do Not Ship" method.

    When using a coupon created in RedShop or no coupon at all, and choosing the Do Not Ship, the Shipping amount in the Cart (ajax) changes to 0.00.
    When choosing the Do Not Ship when an AWO coupon was used, the shipping in the cart remains at the FedEx Home Ground amount.

    It reacts the same in IE 9-10 regular or Chrome, Firefox, Safari
  • Your avatar
    seyi    
     3 years ago
    0

    Hello,

    You are using quite an old version, this problem was fixed in AwoCoupon Pro 2.1.8. You should consider upgrading.

    Here is how you can patch it:

    in www/administrator/components/com_awocoupon/helpers/estore/redshop/couponhandler.php, around line 21 is this
    <?php
        
    function AwoCouponRedshopCouponHandler () {
    ?>


    Change it to this:
    <?php
        
    function AwoCouponRedshopCouponHandler ($c_data=array()) {
    ?>


    Around line 26 is this
    <?php
            $this
    ->rscart $this->session->get('cart');
    ?>


    Change it to this
    <?php
            $this
    ->rscart  = empty($c_data) || count($c_data)session->get('cart') : $c_data;
    ?>


    Around line 32 is this:
    <?php
            $instance 
    = new AwoCouponRedshopCouponHandler();
    ?>


    Change it to this:
    <?php
            $instance 
    = new AwoCouponRedshopCouponHandler($c_data);
    ?>


    That should do it.
  • Default avatar
    peaces    
     3 years ago
    0

    Should I just upgrade and not make these changes?
  • Your avatar
    seyi    
     3 years ago
    0

    Well that is really up to you. The changes should fix your problem but I would upgrade to fix other bugs. You can see bugs fixed with redshop in the release notes:
    http://awodev.com/documentation/awocoupon-pro/release-notes

    If you do upgrade, please make sure you backup the db before doing so.