AWO Coupon Pro reports not working


  • Your avatar
    seyi    
     5 years ago
    0

    I am trying to run a report in order to export coupon data, but when I click the Run Report button, all I get is a blank screen. I need to get in and edit the coupons. Please help.
  • Your avatar
    seyi    
     5 years ago
    0

    turn on debug mode in joomla and run the report again to see exactly what the error is.
  • Default avatar
    foothillweb    
     5 years ago
    0

    I still just get a blank screen.
  • Your avatar
    seyi    
     5 years ago
    0

    then you must have a php error. You can try adding the command to display errors on the screen. In
    www/administrator/components/com_awocoupon/admin.awocoupon.php on line 2, right after
    ini_set("display_errors", 1); error_reporting(E_ALL);


    then go back to the reports page, you should now see the error
  • Default avatar
    foothillweb    
     5 years ago
    0

    Here is the message:

    Fatal error: Out of memory (allocated 66060288) (tried to allocate 1048755 bytes) in /home/chansari/public_html/administrator/components/com_awocoupon/views/reports/view.html.php(166) : eval()'d code on line 2

    Edited to add, we have over 6000 codes in the database, if that makes a difference.

    What I am trying to do, and need to do quickly, is set our existing coupons so that they can't be used to buy gift card products. Can you explain briefly how to do this most easily? TIA
  • Your avatar
    seyi    
     5 years ago
    0

    the easiest way is to run a query statement on the database directly. This would do it:
    UPDATE jos_awocoupon SET exclude_giftcert=1 WHERE function_type2 IS NULL or function_type2 NOT IN ('parent','shipping');
  • Default avatar
    foothillweb    
     5 years ago
    0

    Unfortunately I don't know how to do that. What about the blank screen? It's very important we get the coupons fixed right away. Thanks again for your help!
  • Your avatar
    seyi    
     5 years ago
    0

    You can do that using phpmyadmin.

    I am not sure what is causing your error, but I will be happy to look at it if you send me a private message with admin/ftp access.